Package load time

Hi All,

Our prod server is taking around 40-50 minutes for startup. On analysis, it is the packages that are taking the most of the startup time 30 minutes which is expected. The package loading is by far the most time taking thing for the server. The packages here are designed in a poor way and a heaviest package archive has a size of approx 40 MB.
I was trying to get rid of these heavy startup times by disabling the packages at shut down and enabling them parallely using a startup service that would invoke wm.server.packages:packageEnable from a doThreadInvoke instance thinking that it would load packages parallely. Somehow that does not seem to have done any improvement to the startup time.

Is there any way that the custom packages can be loaded parallely instead of serially which by default webmethods does. Note the custom packages i am talking about have no dependencies on one another

What would be the factors that affect the loading time. The package does not contain any adapter service, just plain flow services. So, i would like to know what factors affect the package load times, just the sheer size or no.of. folders or any other factors would come into play at the package activation/loading.

Also one more strange thing is the largest package there takes in around 14 minutes to start up in production. The production is running on AIX 64 bit (6.5 SP3). I installed the same package on a windows 64 bit 6.5, and it took 7 minutes to load. That was a surprise to me, as i always thought the package loading time should not be different from the IS’s, just if the memory is available it should be able to load it in the same time, may be a minute here and there depending on the processor.
Please let me know your thoughts

Pradeep

I would think you’d want to engage wM for this. Package loading is undoubtedly relatively complex, with a myriad of items to consider.

Pradeep,

I have seen the proposed solution you mentioned used successfully (i.e. bringing the server up with the packages disabled and then enabling them in parallel.) So, you’re on the right track. Make sure you check the packages’ dependencies because those also affect start-up time.

Having said this, I agree with Rob that reaching out to Software AG support would be a good idea. This is a relatively common issue so they should be able to help.

By the way, IS 8.2 loads packages in parallel and you can actually configure the number of threads which are used to load the packages. Of course, I’m not suggesting you should upgrade simply for this reason but there’s light at the end of the tunnel. :slight_smile:

Good luck,
Percio

Thank you folks,

Will look into and would contact software AG.

Regards,
Pradeep

Percio, have you seen that this parallel loading improves start-up time?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.