Output Document Validation Mystery

I had an odd problem with my wM EDI project today.

I’ve accumulated two weeks’ worth of test data for my 820, 850, and 860 documents. I’ve run all of this through my mappings that generate the flat files that I need on the back end. Every one of them compares favorably with the flat files generated by our current translation/mapping s’ware.

But when I ran the tests I left input and output validation checkboxes empty. While reading the EDI GEAR document, I realized my oversight, checked the validation checkboxes, and re-ran the first 820 document. I got a validation error on the output FF: a mandatory field was missing.

I checked the schema - the ONLY record that’s mandatory is the first one. All others are optional. The first record appears properly; its cardinality is one.

When I run in debug mode, the output flat file is generated without a problem.

How can this happen when the small handful of mandatory fields all appear? Is validation turned off in debug mode?

Thanks - %


if you check the validation checkboxes on the input/out signatures panel then the validation will occur against the schema/document.so just uncheck it and also if you want validation then do it in convertToValues(validate=true) itself and this validation is based on the mandatory checkbox in the flatfile schema properties panel.


Thanks, Rama, I’ll give it a look.