Out of memory using non xml indexer

I’m trying to load a Microsoft Excel file with a size of 3.5 Mb into our Tamino database.

I’m using: TResponse response = accessor.insert( nonXMLObject );

But I get an Out of memory error. We have given our Java more memory, but it doesn’t help. So my guess it, that it must be some out of memory in Java in Tamino.

Tamino access failure (INOSXE7126, Server extension failed, INOSXE7114: Java error: Errtext: ‘java.lang.OutOfMemoryError’)
at com.softwareag.tamino.db.api.accessor.TAccessFailureVerifier.newAccessFailureException(Unknown Source)
at com.softwareag.tamino.db.api.accessor.TAccessFailureVerifier.verify(Unknown Source)
at com.softwareag.tamino.db.api.accessor.TAccessFailureVerifier.verifyInsertResponse(Unknown Source)
at com.softwareag.tamino.db.api.accessor.TNonXMLObjectAccessorImpl.insert(Unknown Source) at net.defgo.database.DataBase.insertNonXMLFile(DataBase.java:897)
at net.defgo.course.view.CourseWizardFilesAdd.uploadFile(CourseWizardFilesAdd.java:168)
at net.defgo.course.view.CourseWizardFilesAdd.processUploadedFiles(CourseWizardFilesAdd.java:264)
at net.defgo.course.view.CourseWizardFilesAdd.getFileUploadGUI(CourseWizardFilesAdd.java:87)
at net.defgo.course.view.CourseWizardFilesAdd.getContent(CourseWizardFilesAdd.java:58 )

Any idea for a solution?

We are running Tamino 4.2.1.4

Regards from Ole

InterResearch A/S - Vestergade 9 - DK-1456 Copenhagen K
Phone: +45 70 27 28 72 - Mobile: +45 20 10 21 74 - Fax: 70 27 28 79
E-mail: oen@interresearch.dk - Homepage: www.interresearch.net

How did you give Java more memory?

There is a property (X-Tension Java options) where you can add JVM options. Did you use this? did you add a blank (or any other separator char) as first character ?

Regards,

Julius Geppert
Software AG

Hi Julius,

Perfect - it works… didn’t think of the little blank as first character trick!

Regards Ole