Oracle wmdb connection Could not connect No suitable driver

I am trying to connect to an oracle dbase using an Integration Server 4.6 db Alias. I’m connecting to Oracle db v9.2.0.1 using the clients12.zip file (compatible with my 1.3 jvm).

I’m having trouble with the connect string and url.

This is my format:

URL -> jdbc:oracle:thin://<server>:1521;SID=<dbase>

I’ve tried -> udbc:oracle:thin:@<server>:1521:<dbase> without luck. The driver I’m using is -> net.jdbc.oracle.OracleDriver.

I need to connect over the network to the dbase and I’ve verified that the clients12.zip is in my path (saw it listed in the “about” page).

Any suggestions?

please See this link it will help,
http://www.wmusers.com/wmusers/messages/100/31156.shtml

HTH,

Try using this connect string:

jdbc:oracle:thin:@<server>:<port>:<dbase>

and this driver:

oracle.jdbc.driver.OracleDriver

That worked! Thanks!

i’m having the same problem to connect to the db using pub.db:connect with the following parameters :

DB URL : jdbc: oracle:thin:@localhost:1521
DB User : webmethods
DB Pass: webmethods
DB Driver : oracle.jdbc.driver.OracleDriver

but i’m getting : No suitable driver found for jdbc: oracle:thin:@localhost:1521

Regards

Hi Fiorald,

what is the SID (or the service name) for your database?

What is your IS-Version, JVM-Version and Database-Version?

Note that you might have an unwanted blank character in your URL:
Instead of “jdbc: oracle:thin:@localhost:1521”
it should read “jdbc:oracle:thin:@localhost:1521”.

Maybe should have a look at WmJDBCAdapter too, as it is more flexible to use and also supports databases, which are not supported by WmDB-Package.

Regards,
Holger

Hi Fiorald,

In addition to Holger suggestion,

  1. You need to put ojdbc6.jar in C:\SoftwareAG95\IntegrationServer\lib\jars [If you are on windows or identify the lib/jars dir on unix]
  2. restart IS.

HTH.

Thanks,
Rankesh

@ Fiorald.

In addition to Holger & Rankesh comments, make sure you don’t have extra spaces at trailing and leading when you are trying to configure your JDBC adapter connection on IS page.

And make sure that in Other Properties > driverType=thin

DataSource Class > oracle.jdbc.pool.OracleDataSource

Let me know if you have questions.

hi guys ,

@Holger
i’m using oracle 11g (service name : XE) , Integration Server 8.2 with a JVM 6.0.27.
The blank space in the URL was a typo.

I solved the problems thanks to your replies.

I changed the db url in jdbc:oracle:thin:@127.0.0.1:1521:XE and i added the ojdbc6.jar file on the C:\SoftwareAG95\IntegrationServer\lib\jars how @Rankesh suggested

Regards
Fiorald