OpenVMS - Alphaserver as backup machine for Itanium (Integrity IA64)


I have an Itanium OpenVMS machine running Adabas 6 and also have a retired Alphaserver running Adabas 4. A while ago I migrated to the Itanium machine. I would like to use the Alphaserver as a backup machine in a disaster recovery site.

But I haven’t been able to decompress / re-compress the data successfully. Is it possible to move files from Adabas 6 to 4? When I converted to Itanium, I had to use CVT_FMT utility and this worked, but it is not working in the other direction.

With the first file I tried with about 400,000 records, most of the records decompress/recompress with ADACMP but I get about 1,000 records that do not. I get this message:

%ADACMP-W-ERROR, Field = DP, ISN = 4, Offset= 2835
-ADACMP-W-ERR3, input record too short

Any ideas? Thanks!

As long as you don’t use any Adabas 5 or 6 features (like LOBs or MUs / PEs > 191) you should be able
to decompress and re-compress, provided the FDT is the same on both sides, of course.

So you’d need to check why ISN 4, for example, fails to recompress.

But first you’d need to find out why CVT_FMT fails, you didn’t provide
any information re. what “does not work” actually means.

Thanks for your reply!

No, I haven’t used any new features like LOBs or MUs / PEs > 191. The application and FDT is not changed. I compared FDTs and they are the same.

CVT_FMT did not give me any kind of error message. This is the version of CVT_Fmt I used:

When I converted to Itanium from Alpha, I did this and it was successful:
$ CVT_FMT -l -n file48.txt file file48.out 1 48

When I convert from Alpha to Itanium, I did this:
$ cvt_fmt -l -en file48.txt file48.out 1 48

I suspect this has something to do with “stream_lf” sequential file format. On Alpha, the sequential files generated by ADADCU are “sequential”, but on Itanium they are Stream_lf.
I tried converting the Stream_lf file to sequential with convert /fdl command but that didn’t work. Do you have any further ideas? Thanks!

I found the answer to this. There is a component that can be downloaded from Software AG’s web site called “AXP_convert”. It contains a utility called “cvt2axp” that will convert from Itanium back to AXP (Alpha). It works, thanks. Perhaps I am the last customer to use OpenVMS :slight_smile:

Thank you for sharing,
If I have a chance I will try, then come back to share my results.
I believe I can be as successful as you.