one MWS for multiple process engines


is it possible to connect one MWS to different Process Engines (not clustered)?


You need one dedicated IS for MWs to access the log DB.

However, you can direct several IS (or IS clusters) to the same log databases. As MWS displays all logging information from the DB you can monitor all your processes and even services logging for distributed IS installations from one MWS and it does not need to know about the other IS.

The IS Internal alias (I think the XReff too, but check this if you use it) need it’s own db for every IS (or IS cluster), for TN that depends on the installation.

ok, but that’s not what I meant.
I will try to explain it better:

We have to different Process Engines, running on different ISs and connecting to different databases and brokers.
In MWS you can define different IS for the monitoring, but it seems that there is only one possibility to connect the Process Engine to the task engine. As a result I can monitor the IS, but if I will use tasks, it will not work…

According to my experience you can only configure one IS in MWS and need a common database if you want to monitor several Process Engines. The fact that you can configure several servers in Server Settings does not help for independent Process engines with different databases, but in fact I did 't try this setup as I didn’t expected it to work.

Task Engine is running on MWS but needs one IS (configured in “Task Engine Settings”) to talk to the Process Engines database and receive events.
MWS Monitor needs one IS configured in “Integration Server (Process Engine Host)” to connect to the process audit database and send events for process control.
However several IS can host the process engine as monitoring and controlling the processes by MWS is done via database and broker.

As MWS needs to send and receive events for activating and deactivating processes I would expect your environment to work with a single MWs instance. I think you need one broker and a common database for the affected pools. But again I didn’t try to setup an environment like this.