ODBC adapter - OutOfMemory when making new operation

I am trying to integrate Progress DB of MFG/PRO with any other system using ODBC Adapter.
( I use Openlink as ODBC driver )
and I met the serious problem.

The major problem is following,
when I make a operation on the Adapter connected to huge Progress DB (It has about 623 tables.),
EI runs into hang
and after long time passed, It occurs the error, “out of memory”,
on Adapter installed machine and on Developer machine on which I run EI(Enterprise Integreator)
before EI display the list of table.

After increasing the virtual memory on both side,
I success to get the response.
But, it takes very long time to get it.(over 20 min).

I doubt that it makes some problem
when converting table information from ODBC driver to webMethods document(BrokerEvent) and sending it to EI.

does it make sense? if so, do you know any methods to avoid that problem or Service Pack to fix it?

actually, I have already tried service pack 3 for DB adapter 4.1.1.
but after install sp3, we experience another problem.
at COM.activesw.adapter.database.ODBCDatabase.addUnique()
at COM.activesw.adapter.database.ODBCDatabase.getUserName()


If you know exact cause or have any solution or workarond,
please let me know.

Thank you for your attention.

If all you need to do is selects you might want to think about creating a Custom SQL operation.