Nullpointer from IS-Web-Services call/ DocumentRef-Problem

Hello,

I want to integrate an external Web-Service into the Integration Server, so I created in Developer

  1. an Web-Service consumer with the given WSDL
  2. a flow-service in which I inserted the generated connector
  3. the input and output fields/ (document reference)
  4. the mapping from input to request and response to output

Then I tested the flow-service, it worked fine.
Afterwards I created a provider for this flow-service and tried to call it over saopUI.

I get a Nullpointerexception and the server.log from the Integration Server tells following:
(the external Web-Service was called with no problems HTTP/1.1 200)

2008-12-18 16:58:27 CET [ISC.0088.0001E] SOAPException: [ISS.0088.9133] Error while encoding RPC output
2008-12-18 16:58:27 CET [ISS.0053.0003D] Dispatch caught exception in run loop: null
2008-12-18 16:58:27 CET [ISS.0048.9998D] Exception --> java.lang.NullPointerException

The pipeline looks ok for me.

When I loop over the response items of the external web-service and map some fields to an string-array output it works fine.
(My original output is a document reference that has elements which itselfs are references and so on. )

Why does the entire response (instead of string-array) cause an error?
(Changed all timestamps to strings, checked all mandatory fields,
pipeline.xml (4.05 KB)
KeyTable.GetDetail_test_mini.xml (5.2 KB)