Null pointer exception while saving the service


Version : 4.6, 
Developer : 4.6.1 

I am getting a following null pointer exception when trying to save a service in developer. 

Could not save '<servicename>'.             java.lang.NullPointerException     

Detailed error description : Server error occurred

 I tried clearing the cache and I got the same error. 
"Service cache could not be cleared. 
Detailed error description : Server error occurred 

However I am able to clear the cache from server administrator, like going to the service and then reset cache.

 When I searched for any possible fix in webmethods advantage, I finally got a fix for that, "ID_4-6-1_FIX_1". This I copied to updates folder and then tried to save the service again, STILL NOTHING GOOD... 

restarted the server but still the problem .... 
Any help is really appreciated... 


Can somebody please answer this !!! we are in real hurry to fix this !!!

when you cleared the cache, did you delete the file? what sort of loading is on the machine? is the package showing as being fully loaded? check the packages status via Management from main IS screen.

bit more info needed.

stop IS - got to wmDirectory\IntegrationServer\datastore

delete the ServiceCache file

restart IS

has this service ever worked?

Glad it worked, thanks a lot for the help.