MWS Designer Initial Setup Issue


Recently I have installed MWS+IS+UM version 9.7 and can able to see all components working fine.
I am started doing BPM POC while doing initial setup like configuration of Broker + UM connectivity test in Designer it’s failing with error where I can see in IS admin page my Broker(6849) + UM(9000) are in active state.

Can some one suggestion what went wrong here find snapshots for same

Test connectivity in designer page error message

Connection Failed: java.lang.RuntimeException: javax.naming.NameNotFoundException: [BRN.101.1002] Lookup Error: Lookup failed: Name jms not found.; remaining name ‘“jms/optimize/connection_factory”’


What i guess is it might be issue with jars or classes. Kindly make sure all required jars exist in right location and they are been pointed by CLASSPATH.


Hi MR,

Is it possible to share jars name and directory structure as well as which is the area in class path where i need to modify or verify said solution kind of very bit new to MWS stuffs even run through docs not able to grab required information to close this issue and struggle with initial setup.

Even I have seen this issue on wM 9.7. I am currently on it, will update you once I find the fix. Meanwhile you do the same. :slight_smile:


Exactly I can’t figure out what all jars needed, but if you read admin docs, probably you will list out all needed jars.


@ MR
Just a question how do you say that there are some missing jars? Do you have any docs that talks about this jar anywhere?

I see the error is something related to “An object with the given lookup name is not found in the JNDI.”

Share your views please.

Hi together,

I cannot see an issue with classpathes here (would have been something like “Class not found”).

More likely there is an issue while configuring/creating the objects on either Broker or UM causing the connections to fail as they cannot find their requirements.

I am not sure if this is caused by using Broker and UM in parallel.

In my project we are still using Broker 9.5, as UM 9.5 is not yet able to deal with native publish/subscribe.

I have never used UM due to the restriction mentioned in the last sentence.


Have you found the solution? If yes please let me know, I am also facing the same problem

Hi everyone,

This happens when the connection factory “jms/optimize/connection_factory” can’t be found in your Connection Factories.

Check your UM Enterprise Manager > Universal Messaging Enterprise > Realms > .
Click on the “JNDI” tab, and you’ll find the NameSpace panel below. Might take a while to load.

Locate NameSpace > [nsp address] > Connection Factories. Right click on the folder and choose “New Connection Factory”. Enter “jms/optimize/connection_factory” and try again.

HTH :slight_smile:


You can find an article related to this error –|Error:|Lookup|failed:|Name|jms|not|found&SessionID=128172932

I hope you are working on wM9.7. Kindly update the forum once after doing the changes.


Hi all,

I can’t create a connection factory in my UM Enterprise Manager like this picture below.
am I missing something? or there are another step should do.
I have 9.9 version.

Thank you.

Hi all,

I tried to connect to my UM server from IS server. I tried to enable IS_UM_CONNECTION but I get this error.
I think I did some mistakes, but I have no idea about that.

Please help.

Do you have Optimize for process or Optimize for infrastructure configured? AFAIK queue in question gets created when you configure Optimize in MWS.
Second look at your Process model and if you are using any optimize related property. KPI etc. that may be causing this error.