MQSeries Adaptor V3.0 on IS6.0

I am trying to make use of the MQSeries adaptor and have run into a couple of issues/questions, anybody using MQ and seen these?

  1. Using a listener handler, I want my messages to be processed concurrently (i.e. multi threaded) on the IS. How do I do this? out of the box the messages are processed 1 by 1.

  2. If I disable my listener handler then the handler continues to be called as messages are put onto the queue. This is after a message has been received and the shutdown timeout has expired. If I delete the handler from the IS, then this makes no difference either. In fact, the only way to stop this handler seems to be a restart of the IS.

Can anyone help?

Michael,

I’m fghting with this adapter, but I just finished configuring it and testing it with only one message in the queues…

If it works like you say I’ll be in trouble too,

do you publish the messages in the broker? or you don’t use it…

do yo have an email to get in touch when I come to test the adapter in these days so we can help each other?

Hi Ariel,

you can contact me at michael.devine@orange.co.uk

Currently, I am upgrading to IS 6.0.1 to see if that helps (doubt it) and then I will pass the question out to Webmethods.

Mike

we use MQSeries adapter 2.0 with IS4.0 and the way we handled multi-threading with MQ messages in two ways. One way is to create multiple listers for the same queue - this gives you a nice way to control how many threads you allow.
Another way is to create a java service which uses Service.doThreadInvoke service to invoke the final service. The problem with this is you have no control on how many threads start, if you have 1000 messages on the queue, then 1000 threads will start at just about the same time and process each message independently.

Hi Rosa, thanks for your post.

I just tried upgrading the IS to 6.0.1 but no improvement

Your first suggestions is how I expect the listen handler to work - unfortunately it doesn’t for me - I’ll explain what I have done. I have generated 2 listener handlers called listen_a and listen_b. Both listeners call a common service, called myRouter, which calls other services based on the message content. When I feed my messages into the MQ I can see then being read by the listener 1 by 1.

I understand your second suggestion but I need to research the doInvokeThread service a little further. However at first glance it seems that this is not how one should be working within WM.

Personally, I wanted to be prompted for how many threads should be permitted to handle messages
when I created the listener handler. After all there are plenty of occasions when you need to deal with messages 1 by 1 as well as concurrently.

If I can get solution 1 working then this will be fine, and I shall be a happy man.

michael.devine@orange.co.uk
Bristol, UK

I’m actually quite surprised to hear that anyone is using the webSphereMQ adapter for Integration Server with any degree of success. We tried it out here, and it was so horrendously buggy that we had to revert to using the Enterprise MQ Adapter. I just recently received a boatload of fixes and patches from webMethods for it, as we escalated the issue through our webMethods System Engineer. I have yet to try to them, but hopefully it will fix some of the problems and prove to be more stable than previous versions…

We had problems with our listen operations as well. Sometimes they would work, sometimes they didn’t. Lots of intermittent problems, inconsistencies, and things like that really scared us off from using the webSphereMQ adapter. At least the Enterprise version behaves consistently…

Brad,

Not sure if it is my own paranoia but I actually really like it when someone else describes experiences exactly like my own.

I have seen lots of intermittent problems with this adapter and thought it must be me doing something wrong. Perhaps not.

I have applied fixes SP2 but not SP1 to my adapter with no improvement. I’d be interested in knowing what level of SP you have tried.

michael.devine@orange.co.uk

Michael - webMethods recently sent us Service Pack 2 and Fixes 1-4. I think Service Pack 2 encompasses all of the fixes in Service Pack 1. Sounds like Service Pack 2 didn’t do a lot for you. Have you tried Fixes 1-4?

I am hoping to apply these fixes and test them out some time today or next week. I’ll let you know if I see any improvements. It might take some time to get everything setup again, as we totally scrapped the webSphere MQ Adapter and un-installed it on our servers.

I’ll let you know if I see improvements after testing with all of the fixes…

I’m with the same problems… like you guys,

Brad,

are those Fixes for download?

I installed SP2 but I didn’t find those fixes…

Ariel - I would assume that they are available for download. I got them from webMethods support.

If you can’t find them and can’t get them from support - you can post your email address, and I will send them to you…

Brad,

here’s my email

ariel_martinez@infojbs.com.ar

I can’t find them for download…

thanks a lot,

Brad,

Can you send the fixes to me at
michael.devine@orange.co.uk

Cheers

I’m having problems qith this adapter again…

The problem is with the Connection Pools, I get an error “Can�t get connection from pool”
sometimes in one Get service other times in a Put service…

I think it has to do with the Mins and Max connections…

dose someone have FIX 1 through 4 ?? I can’t find them for download…

somebody can help?

Ariel - Post your email and I will send you the fixes…

Brad

Hi, guys. We use MQ Adapter 2.1 on BC 4.0.1 and I tried more than one listener and it seemed to work. One of the thing to consider is whether your service is Transactional or not. If it is transactional than the listener will probably lock the queue until after commit issued by your message service. If it is not transactional then message will be taken from the queue instantly but you would loose MQ Assured delivery.

Hi

We are facing one unique problem of loosing our Msg Handler Services(Get and Put) after the Server is rebooted. Though we can see the service in the Developer but it
is not there in webSphere MQ Adapter Console .

We need to always recreate the MsgHandler service once
the server is started

Please let us know if anyone you faced a similar problem or any workaround …

—WebShpere MQ Adapter version -3.0
(Applied SP2and SP3, Fixes( 1 to 6)

—IS Verison 4.6.1 (with SP2)

Thanks
Shibu

I am just now installing the MQ adapter for MQ 5.3 , I am trying to download j2ee.jar from sun’s website and having a hard time finding it , can somebody give the actual url.
Thanks

I tried downloading j2ee 1.4 from SUN’s site but my install never quite worked right. I planned to try again using 1.3 but have not done it yet. Here is a URL.
http://java.sun.com/j2ee/1.3/download.html#

let me know how you get on.

michael.devine@orange.co.uk