Monitor Service Performance

Hi All,

We’re trying to set email alerts for API availability by creating a global policy for Traffic Monitoring -> Monitor Service Performance and selecting “Availability” as the action configuration.

I’ve been trying to get an email alert to fire with no success. I set the rule to “Availability” is equal to 100 with an interval of 1 minute and frequency to “Every time”.

Does anyone have experience configuring this?

Thanks - Jam

Hi Jamila,
Can you enable Destination “APIGateway” along with Email and Then try invoking the API.
After which, invocation of API will send events to APIGateway. which can seen in Analytics Page of APIGateway.
This will help in validating whether there is problem in event generation or sending the generated event to specific destination.
And also you please verify whether Email Server Settings are correctly configured.
You could use the “Test” option from configuration page to verify the same.

Thanks
R.Sreesaran

Thanks for your inputs Sreesaran.

I did select API Gateway as a destination as well as the email and I’ve configured the Email already (using a fakeSMTP on the same server). The email configuration works (during Test as well as selecting email alert for a different global policy regarding Log Invocation).

However, it’s not working for Monitor Service Performance - Availibility.

Right now I invoked the API twice and see two new transactional log events for this API in the Kibana analytics. Is this the type of event I would expect or a different event type based on the global policy in question?

Still no email though.

Hi Jamila Hojas,
Transactional Events are generated when a policy with Log invocation policy action is enabled. Here Monitor events should get generated.
[img]

Sreesaran, I can confirm that no events of type “Monitor” are reflecting in the API’s analytics. The only event types are PerformanceData, Error, and Transactional. The Error events are when I deliberately routed requests to a dummy endpoint.

Knowing that Monitor events are not occurring, do you have advice on what could be the cause?

Jamila,
What is your APIGateway Version and which version are you currently in ?.

Thanks
R.Sreesaran

I’m using API Gateway 10.1

What is exact Fix Version ?.

Fix Version 16.

Hi Jamila,
I tried out the exact scenario.

  1. I had created a Rest API
  2. Added the Monitor Service Performance Policy
  3. Added the “Availability” with value set as 100
  4. Alert interval set as 1 and Alert Frequency as “Every Time”
  5. Activated the API
  6. After two invocation, i was able to see a Monitor Event generated in API Level Analytics Page

The issue is not reproducible. I am using APIGateway version “10.1.0.16.335”


Thanks Sreesaran, I checked the API Gateway version and stand corrected, my version is: “10.1.0.10.231”. This could probably be a bug and the reason your settings work and mine do not.

@Sreesaran, I created the Monitor Service Performance at API level and it finally worked :). Thanks!