Modify FDT

I have the DBA Workbench V6.1.9.02 coming with NaturalONE CE 8.2.

In order to modify a Field Description Table (FDT) the Help says:

  1. Select the file whose FDT you want to modify from the Files window.
  2. Choose Modify FDT from the Administrate menu.

However, when I attempt that on one of my files, the menu item is disabled (greyed out).
Is it a limitation of the community edition?
How else can I modify attributes of existing fields?

Is there a documented list of all limitations?

Thanks for your help.


Hi Hubert,

When you start the DBA workbench, try right-clicking and select “Run as administrator”.


Graeme Lane

Thank you Graeme,
that works fine.

I just found out that things are different.

Help is wrong.
It is not sufficient to simply select the database and the file.
“Modify FDT…” remains disabled as long as the database is inactive.

Starting the database to which the file belongs enables the menu item.

I cannot tell what difference the administrator role really makes.

Thanks, anyway.

  • By using ‘modify FDT’ you can change only the ‘Length’ of the fields and their ‘DDM DC’
  • To Add Descriptor to a field, choose ‘Descriptor’ from Menu then ‘Invert’, you can now enter the field’s name, choose Descriptor and set Unique property then click ‘Add’.
  • To remove Descriptor from a field, choose ‘Descriptor’ from Menu then ‘Release’, you can now select the field’s with double click and click ok.
  • If you want to change the name of the field or its format, then remove it and add it another time with the new properties.

I hope this will help you!