Microsoft Navision webservice

Hi Guys,

In my current assignment i am working on a intergration of webmethods with MS NAV DYNAMICS webservices, I am trying to consume NAVISION webservices but pretty much stuck with SOAP processing errors.

I am able to invoke the service but getting the response – SOAP fault that soap msg is invalid… i am pretty much using the standard soap 1.1 request with no input required for webservice…

So was wondering if anybody has done this successfully?

I had some issues with a web service with out inputs in our current 8.1 env. When i send an input to the web service, even though the consuming WSD does not require an input, i get a valid response back.

I created a dummy doc Temp1 and created a string String1 under it. After that hard coded some value in to this String1 and mapped this doc to the input of the WSD. It started to work.

In my case i got an EPR (End point Reference) not found error.

Note:
I was using web service aliases.

Cheers,
Akshith

thanks Akshith for your input.

Noticed that there is this option in SOAP UI “Strip Whitespaces” when i am setting it as true, my webservice call is working… is there any way to set the same from webMethods. I did tried to trim the WS Request it hasn’t worked.

Any ideas guys?

thnx.
naren