Measurement ouput display on the KPI trend widget

What product/components do you use and which version/fix level are you on?


Is your question related to the free trial, or to a production (customer) instance?


What are you trying to achieve? Please describe it in detail.

We observed that within 1 hour if there is new aggreagted meaurement ouput then KPI trend widget displays the 0 and after 2 hours or 3 hours if there is new aggregated mesaurement output it displays the aggregated value on the widget.

at 13:15 this aggragted value

Now new aggregated for 2 hours.

at 14:50 the new aggreagted value.

This analytics model.

Do you get any error messages? Please provide a full error message screenshot and log file.

How to avoid displaying 0 when there is no new events but instead show the last measurement in the time.

Have you installed all the latest fixes for the products and systems you are using?

Can you provide more details about what you want to achieve and how you have configured the Cron Timer block?

If the expectation is the Counter should be be the number of daily packages (each represented by one event) then the model should work as expected granted the Cron Timer is configured to be reset each day at midnight. In that case, a 0 value before any package is received for the day would be correct for me.

If you really need to filter out 0 values, you could use a Gate block that is disabled every time a 0 is produced.

We are trying achieve the KPI - number of products produced.
Whenver a new product produced our device detects and send it as event to the cumulocity IoT. The below model recieves pulse whenever new evnet or new product produced and then it trigger the counter to caluclate the count.
The Cron timer in the model is reset to the midnight 24.00:00.

The model throughput is correct which is verfied by querying the device measurements api. Its not about the model but more about the KPI widget. Sometimes products are not produced for 3 hours and during these three hours KPI widget displays zero. When a new product is produced it display the count correctly.

If the I understood correctly, The counter block will not be triggered if there is no new event which means that there will be no output.

The KPI widget which takes output of model, displays the last mesurement for 1 hour and then it starts showing zero till a new event is produced.

What value have you configured for the property `KPI aggregation interval’ in the KPI trend widget?