Match Payload Property for REST V2

Hi Techies,
we recently migrated from 912 to 10.5
We found a new feature added for REST API Descriptor (RAD) in 10.5 called ‘Match Payload with Swagger’. It’s true by default. Is there a way to set it to false for all APIs via any extended setting?
Currently our inbound API invocations are failing as the RAD is not able to match the incoming JSON requests (which is another issue we need see why not).
For us to carry on to PROD, we need to get this fixed, either manually by setting the value to ‘false’ for every API(over 100 APIs) or through a global setting.
Any help would be appreciated.
Thanks.

Info from empower community …

Thank you Dinesh.
I have another question.
I tried to promote the manual changes that I did for the individual RAD, but deployer would not recognise it. I get the below error

[DEP.0002.0073] Deployer could not add component a2a.api.sap.getEmployeeData:getEmprad of type Unknown

Do you have any idea on why it’s this way?
Thanks for your help Dinesh.

Swagger document defines how request payloads should be strcutured. With this property set to true, user need to use structure of request payload as defined in swagger document. For backward compatibility reason, this property on RAD was introduced to allow user to have old APIs work with similar structure but all new APIs are implemented with corrects payload structures.
Global extended property cannot be provided for this setting as it will be a global setting and even enforce the setting on new APIs as well.
The only option for this is to change the property to false on each RAD after migration.

You will have to deploy the complete package Rama.