Localhost Integration Server

I get error “Connection failed for localhost:5555 (there is no Integration Server on the specified port, or the proxy server is not available)” when I try to connect integration server

IS.PNG

Hi Serhat
Did you started IS already ?
Can you open a command line and try Telnet localhost 5555 ?
Or you can try the browser http://localhost:5555 ?

1 Like

Hi Onur ,

Thank you for your reply .

I tried to start integration server by clicking the file you can see IntegrationServerStart.png but it didn’t work .

When I try telnet , I get “Could not open connection to the host , on port 5555 : Connection failed”

I try on browser but I get the error in localhost.png (attached file) .


Hi Serhat,

if you tried to start this instance, there should be something in the server.log which indicates why startup failed.

You can investigate for profiles/IS_default/logs as well to see if there is anything in the wrapper.log.

Regards,
Holger

Hi Holger ,

Yes I tried to find server.log but there is only WebSocket.log exist in the folder :frowning:

Hi Serhat,

which version of IS are you using?

We will definitely require the content of C:\SoftwareAG\profiles\IS_default\logs\wrapper.log for further analysis.

Regards,
Holger

Hi there

I am facing the exact same problem with version 10.5. Firstly, I don’t have an “IS” folder under profiles, I only have an SPM folder. Running the startup.bat through CMD (I’m on windows 10) and I get the message status “RUNNING”.

Please assist.

Hi Darryl,

There should be a folder like IS_“instanceName” under profiles under which you will be having sub directories for starting the server and logs, configurations etc.

How did you install this IS? From command central or SAG installer.
What is the operating system you are using?
What are the directories you are seeing under SAG/IntegrationServer/instances/default/*
Are you able to start this from Windows Start - Start as a Administrator.

Regards,
Firoz N

1 Like

Hi Darryl,

Please check on the IS (standalone basic) installation part mainly and confirm the folders and logs

check under SoftwareAGIntegrationServer/instances/default/logs - (server,error,session files if any exists) and wrapper.log under (SoftwareAG\profiles\IS_default\logs)

HTH,
RMG

If you are not seeing profiles/IS_ folder, there is a possibility that instance creation failed. Can you please have a look @ IntegrationServer/instances/logs directory and see if logs located under it provides any information?

Regards,
-Kalpesh.

Hi Kalpesh

Thank you so much for the reply; so managed to figure out what I needed to use was the Natural IDL selector and not the webMethods one, but I’m now having a different issue; please see screenshot below:

Any idea what that error is/means? I’m able to ping the mainframe so it is visible to other computers on the network.

NAT1696 means what it says on the tin: “logon to library denied”.

This message doesn’t show the reason code, so try to log on with the given credentials interactively and you should see the real cause.

Hi Wolfgang

Tested logging onto the mainframe with the credentials and this logged on fine with no issues. Is there any other way I could determine the reason for logon being denied?

Darryl,

check the RPC server log, you’ll probably find a more complete message, including the reason code, there.

Thank you Wolfgang, will do so!

Apologies for all the questions; I’m fairly new to EntireX and the mainframe side of things.

No problem at all :wink:

Hi Wolgang

Problem resolved; the account I was using was not setup correctly with Natural Security. Thank you so much for your help! :slight_smile: