Keystore reload issue

Hello All,

We have UAT B2B cluster environment and one node having an issue with Keystore while reloading. One node is fine and all keystore are active and running. When I tried to reload the other node Keystore its showing failed.

KSA.ksWrapper.CantInitStoreE] attempt to initialize keystore using location(/xxxx/xxxxx/IntegrationServer/instances/default/config/security/keystore/UATA2Akeystore) failed

I replaced the Keystore file with working node and restarted the server but no luck.

Any suggestions will be appreciated.

Thanks and Regards,
Masroor Alam


in few days ago we found same issue in one our UAT node. All remind UAT nodes (same configured) working fine. Only one node has issue to load/reload keystored for provider SunJSSE.

Did someone found where issue is or can someone help with some ideas?

Ladislav Smetana

Hello Ladislav Smetana,

Please share the logs during the reload time stamp so that we can understand the reason. Also please check the alias name and other parameter configured into keystore. Please compare the configuration with other working nodes. you can also check configuration through IS console.

Masroor Alam

Hello Masroor,

I have compared it. All is same. And it worked before. All nodes using same P12 file.

In log unfortunately is only this record:

server.log:2017-10-06 13:19:44 CEST [KSA.ksWrapper.CantInitStoreE] attempt to initialize keystore using location(/apps/wm02/security/ failed

Nothing more.:frowning:
I was tried to find anything in any log but nothing there.

When I have converted this P12 to JKS, it working… so only P12 stopped work.

Many thanks for ideas!


Hello All,

found solution.