JVM shutdown Hook

Hi,

In one of our optimize integration servers, daily morning the server goes down with this error:

012-09-08 06:15:00 CEST [ISS.0014.0005I] Shutting down server. JVM Shutdown Hook.

JVM details:

From server.sh: JAVA_DIR=/usr/lib/jvm/java-1.6.0-ibm-1.6.0.8.x86_64/jre/
From jcode.sh: JAVA_DIR=/opt_is/jvm/linux150/bin

Please check and provide suggestions on this.

Many thanks in advance.

Someone calling a system.exit() in your integration server?

Is there any unusual script running abruptly or another unix job doing this and also contacted your sys admin?

Or the JVM is not being executed with nohup and is terminated when the user that starts it logs off (or is forced off)?

If I start the server with nohup ./server.sh & it starts up and immediately shuts down(not happening all the time but sometimes) showing the same error. Later the next day at 6:15 it goes down with the same error.
@reamon: How to check if the user is forced off but I don’t think this is happening in this case here?
@rmg: Reg. Linux job I will check with lx admin.
@griffima: where can I check for this system.exit() ?

What is your IS version?

IS is running on Webmethods 7.1.2.

Any inputs from your lx admin? as he is the best bet to check more for you dealing with your OS environment.

Issue got resolved. Server was going down everyday due to a scheduled service created for livePurge because of wrong syntax for db_url in the config. I corrected that and ran the service, the server continues to run.:slight_smile:

great…see what a pain right?

Any idea what caused this wrong syntax in the db_url to trigger JVM error?

I am not sure…Is it a wM provided script or custom?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.