JDK Version for EAI Adapters

I installed 4.1 EAI then 4.5 EAI, defaults.

I have the same need for JDK 1.3 with some
custom code hitting a WebLogic 6.1 server. Replacing the 1.2 JDK with 1.3 solves my problem. I have a support request into WebMethods for their answer on this. When I get a response from them I will post it.

WebMethods support does not recommend swapping out the JVM that comes installed with the Adapters. They also said they are not certified on JDK 1.3 so it is use at your own risk if you decide to swap out. Currently the latest adapter versions are 4.2 and those are also JDK 1.2 based. There was no estimate on the timeframe when 1.3 certification would take place. Also, no recommended workaround for this issue.