JDEWorld Adapter Problem generating service


I hope someone here can help as I haven’t been able to find any more information.

When we try to generate services using the web administrator for the JDEWorld adapter, we get the following error: ‘Couldn’t Register <servicename> ;error logged’.

The problem is I don’t see any info in the log, and nothing on the JDE side. Does anyone know what wM is trying to do when you generate a service.

We have successfully installed and configured the JDEWorld adapter on an installation of wM 6.1 (NT). The JDEWorld adapter is configured to access the JDE system on an AS400 / DB2 system.

Here is a list of things we have tried so far:

  1. Executing some of the pre-built transactions (including GetNextSequenceNumbers) and get the following error:

    Could not run ‘GetNextSequenceNumbers’.
    com.wm.app.b2b.server.ServiceException: Select transaction failed:[SQL0204] SEQNUM in *LIBL type *FILE not found.

    We know that the SEQNUM table exists and we can select data from it using the profile (through a JDBC adapter service).

  2. Creating a new transaction and generating a service based on it.

  3. Using a username/password that has full object access on AS400.

  4. Using the JVM that comes with the IS6.1 install.

  5. Using JVM 1.4.2 on the IS.

  6. Ensuring the Schema name is NOT populated in the JDEdwards Adapter Alias.

  7. Creating a new Package , with a new folder. We still get the same error.

  8. Executing a SELECT JDBC Adapter Service against the SEQNUM object (to confirm that it is set up correctly).

  9. Configuring a JDEdwards Adapter connection on IS 6.0.1 and IS 4.6 (to make sure it’s not an IS version issue).

and none of these things work.

Any help would be great.


I worked only with 4.6 only and I can tell you olny about yours 1 error…SEQNUM in *LIBL type *FILE not found.It seems that the file is not journrled. Just check this.

Ajay Arora