jdbc service returns gmt instead of time in db table

I have a jdbc adapter service which calls a stored procedure, which returns a timestamp. The problem is the adapter service automatically converts the timestamp to gmt. anyway I can stop it from doing the conversion? I just want the timestamp as is in db. BTW, I am using 7.1.2
Many thanks

saving time in DB with GMT is good practice. The client should do the conversion base on the user/client locale. Do the conversion yourself after retrieve it.

Thanks, and whether it is a good practice or not, in my view, depends on the application. But that is not the issue here, the problem is the adapter automatically convert date to GMT. Should have an option to have the conversion or not.

It’s not the adapter doing it. It’s the driver.

The jdbc driver? I am a bit confused here, care to elaborate? Thanks

The driver, not the adapter, applies the client locale. To control the driver you can either change the appropriate client config files or I think you can set additional parameters in the adapter connection config (which are passed through to the driver).

but isn’t locale more of a language issue than timezone issue?

Strictly speaking, that’s true. Locale deals with language and formats. Sorry for the misdirection.

I guess my main point is to focus on how to configure/control how the driver behaves rather than the adapter.

ORA_SDTZ is an environment variable that can control the default session time zone.

I’m just speculating on what may be happening but I’m fairly confident that it is not the adapter. Instead, it is likely to be the configuration of the DB itself and the driver (and any other tools you’re using to view/test the stored proc results).