JDBC Connection Problem

I’m getting the following error while trying to create a JDBC adapter connection.

Error encountered [ART.118.5011] Adapter Runtime (Connection): Unable to create new connection JDBC:

The error is kind of cyptic so I’m not sure exactly what might be wrong. The network protocol setting I’m not quite sure what the values should be and the documentation doesn’t give any clues. Here is how I have it setup. Does anyone see what I might have wrong?

Transaction Type = LOCAL_TRANSACTION
Source Class = oracle.jdbc.pool.OracleDataSource
ServerName = (host name of my oracle server)
user = (user name)
password = (password)
DatabaseName = (Oracle Schema name)
portNumber =1521
NetworkProtocol=TCP
Other Properties=driverType=thin

Thanks,
Tim

I can see two possible problems.

  1. The source class is unknown to me, but may be adequate nonetheless. Try using oracle.jdbc.pool.OracleConnectionPoolDataSource instead.

  2. You may not have the Oracle JDBC drivers properly installed. Verify that your WM_HOME/IntegrationServer/lib/jars folder contains classes12.zip. If you don’t have it, copy it from your ORACLE_HOME or download from www.oracle.com.

Note that this cryptic and generic error message can contain all kinds of errors. Check your error log for the causing exception, WM_HOME/IntegrationServer/logs/errorDATE.log.

Oracle 8i.*
Webmethods on W2000
classes12.zip in IntegrationServer/lib/jars

Using:
Transaction Type LOCAL_TRANSACTION
DataSource Class oracle.jdbc.pool.OracleDataSource
serverName feynman
user a014993
password ******
databaseName cmappd01
portNumber 1521
networkProtocol TCP
Other Properties driverType=thin

Get the following errors:
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource jdbcConnection:daveTest.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
Invalid Oracle URL specified: OracleDataSource.makeURL

Hi David,

Try using oracle.jdbc.pool.OracleConnectionPoolDataSource in DataSource Class.Double Check the values serverName,databaseName and Port.

Cheers,
Thota

Try IP Address instead of serverName.

I’ve seen a lot of posts about JDBC Adapter connection problems, but unfortunately I am still getting an error:

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource Test:CortConnection.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
[wm-cjdbc31-0006][Oracle JDBC Driver]Unable to connect. Invalid URL.

Does anyone have any suggestions or tips to try? I’m using the standard connection parameters:

Transaction Type = NO_TRANSACTION (i’ve also tried LOCAL_TRANSACTION)
DataSource Class = oracle.jdbc.pool.OracleDataSource
Other Properties = driverType=thin

Thanks
Cort

Hi Cort,

Are you create separate package for adapterConnection in developer. 

(ex:WmDbConnections.In that create folder,subfolders).Now open Administrator.Click on JDBCAdapter under Adapters.Edit.Make sure that
You have to specify Package name from pop-up menu.Select package name as WmConnections you have created earlier.give foldeer name as foldername.subfoldername you have created those under package WmConnections.Now give connection name as Test in Connection name
box.Now select TransactionType as LOCAL_TRANSACTION.
DriverClass as oracle.jdbc.pool.OracleDataSource.Then serverName,
user,password,databasename,portnumber,otherProperty as driverType=thin.
connectionManagement properties are select Enable ConnectionPooling as true.set other parameters like min,max poll size.etc.Then click save Connection butoon.It will works you.

Regards,
SriniK

Hi all,

I’m a WebMethods newbie and I’m trying to configure a JDBC Connection to an Orable DB. And after editing all parameters I’m obtaining the next error:

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource Connection:TestConnection.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleConnectionPoolDataSource”.
Excepción de E/S: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=135296000)(ERR=12505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))

This is the configuration I’m using:

Transaction Type : LOCAL_TRANSACTION
DataSource Class : oracle.jdbc.pool.OracleConnectionPoolDataSource
Other Properties : driverType = thin

Does anyone knows what I’m doing wrong?

Thanks in advance,

Ignasi

The following settings work for me to connect to an Oracle 9i RAC instance (I’m not using the OCI drivers for failover support just yet)

Transaction Type LOCAL_TRANSACTION
DataSource Class oracle.jdbc.pool.OracleDataSource
serverName hostname
user username
password ******
databaseName databaseName
portNumber 1521
networkProtocol not specified
Other Properties driverType=thin

These settings allow me to connect using the XA transaction type:

Transaction Type [i]XA_TRANSACTION [/i] DataSource Class [i]oracle.jdbc.xa.client.OracleXADataSource [/i] serverName [i]hostname [/i] user [i]username[/i] password [i]******[/i] databaseName [i]databaseName[/i] portNumber [i]1521 [/i] networkProtocol [i]not specified[/i] Other Properties [i]driverType=thin [/i]

HTH,

Mark

i had the same problem as that of many of the others
but the reason for my problem was that
my oracale server was not started

before doing all the connection check whether the oracle is startes at the controlpanel/services

Hi all,

It’s obvious I’m a newbie in the world of WebMethods. Sorry.

I’ve realized that when I execute for the every first time my adapter service (JDBC adapter) it all works fine, but whenever I try to execute it later, it fails (in fact, what it happens is that keeps in state “running” for hours).

Does anyone have any idea what’s going on ?

thanks in advance,

Ignasi

Hi all,

I think I’ve finally been able to determinate what’s going wrong with my JDBC adapter service. The tables where I’m trying to insert don’t have primary key (instead of this, a unique index is used). If I insert a record and then erase it, when afterwards I try to insert again the same record my service generates an infinite loop, and doesn’t seem to finish.

Does anyone knows if this can be solved without modifying my tables definitions?

Thanks in advance,

Ignasi

Hi all,

I’ve already created a JDBC adapter connection, and various adapter services. Now I’ve moved those services to another package but I’m not able to do it the same with the JDBC adapter connection. How it can be done?

I’m supposed to create a new connection and therefore all the services?

thanks in advance,

Ignasi

Ignasi,

You can use the JDBC Adapter’s admin pages to copy the adapter connection to a new package and folder. Click on the icon in the “copy” column on the row where your adapter is listed. You will need to respecify the login password, retry count and retry timeout settings, but all of the other information is preserved.

Mark

Hi, there,

Has anyone ever encountered this problem (below) when trying to enable JBDC Adapter connection to a Microsoft SQL 2000 database?

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource wmtraining.JDBCAdapter.Services:wmtraining.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
javax/sql/DataSource

The 3 jar files for MS SQL 2000 have been placed in <is>/lib/jars. IS appears to be able to load the driver but failed to create the connection.

Any help would be much appreciated.

BTW, we are using webMethods 6.0.1 (build no. 425).

Cheers,

Jin

AFAIK i guess MS SQL JDBC Driver has two types of jars (signed and unsigned).Pls try the unsigned one and also checking JVM version…
is there two versions of JDK in classpath.

~Prabhu

I am trying to configure a JDBC Adapter for WM 6.0.1
I have WM running on a MS W2K PC and my Oracle db is on HP-UX 11.0
(version 9.2.0.3). I copied the ojdbc14.jar file (Oracle asks us to
use this instead of classes.zip for Java >= 1.2). I currently have
Java SDK 1.4.1 on my PC.

When I try to enable the JDBC Adapter I get:

Error encountered

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource D106Exercises.adapters:D106Adapter.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
Prohibited package name: java.sql

I can’t find information on this error.
Any help is appreciated.

Thank you
Subu

Suba ,
It might be better to start a new thread on this but here is my thoughts. webMethods 6.0.1 is running on the JVM 1.3.1 that was installed on it most probably. Try entering a coomand like this in a DOS windw:
<webmethods>\jvm\bin\Java -version
You could edit your server.bat file to find the JVM 1.4 you have on your system (maybe c:\jdk1.4\bin). Then restart your Integration Server. I don’t think JVM 1.4 is recommended for webMethods 6.0.1. I noticed that some java services don’t work with JVM 1.4 (ex. PSUtilities.Misc:AppendStringListToStringTable). You might have to change some of your Java code.

Now webMethods6.1 runs under JVM 1.4.1 - you can check the version as I explained above. The ojdbc14.jar file works with JVM 1.4.1. I have it installed on the AIX 5.2 operating system in <is>/lib/jars. I had to change the permissions on it but it works fine.

Hi Vishal,

There can be invalid user credentials passed to connect to the database. These parameters are given when we create the jdbc connection pool alias. This can be one of the reason. Check this.

shiva

If you are using windows make sure that webmethods is installed directly under the C or D drive and not under Program File (SOme times this will create a problem ) .I made this change and it is working fine

Srini