JDBC Adapters Select output


I’m having a problem with the output of Select Adapter service.
I’ve set up a JDBC connection and then created a Adapter service, in the output of the service, you have a document with the name AdapterServiceNameOutput, as usual. Under than you have a document list called results, as usual. What is strange is that the results document list is an array, I believe, because it has after his name.
When trying to map the values of the result, it doesn’t do it.
Question: how to male a normal document list of results or how to map an document list array?

any help is welcome!!


Good Morning:
I am not completely sure what you want, but I guess you are having problems to extract values from the resultset.

I normally create a LOOP step with the AdapterServiceNameOutput/results as in-array. This allow me to access to the single documents one by one and link them to other variables in case I want to. Have you tried this or perhaps I am not understanding exactly what you want?

Gonzalo Pérez-Prim López

Hi all,

we have to declare the output variables in the Custom select SQL service and those comes in AdapterServiceNameOutput/results. Is there any other way that we don’t need to declare the variables.

i.e. if we write a select statement, it must dynamically get the variable names(as columns in table) in the results document list. Is that possible.

Thanks and Regards,


thanks for your quick response. I tried to loop over the results, and it goes in the loop but it does not copy the value??? It seems to loop over the document list but not over the array, it’s very strange.

Can you check something for me? If you create an adapter service and you go to the adapter settings, in the adapter service template, do you see SelectSQL or com.wm.adapter.wmjdbc.service.Select?



u have to map results to a document which u r using in the loop


Hello All:

Claire, you want to map to a single document, a single variable or to another document list or array?.




I want to map to a single variable.
What I do now as a workaround, is map the output of the adapter service to an objectlist called results. I loop over results and in this loop, I loop over results/results. That is the only way, I can access the variable…Pretty complicated to retrieve one value…

Anybody other possibilities?