JDBC Adapter Connection fails after install of IS61_SP2

After installing IS61_SP2 my JDBC Adapter Connections failed.

Error encountered

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource ari.files:selectSIRI11.
[ART.118.5063] Adapter Runtime (Connection): Unable to start connection ari.files:selectSIRI11: after 1 attempt(s).

I have both oracle and MsSQL-connections with same result. By unistalling SP2 it all function OK. Anyone any ideas ?

Hi Arild,

which Driver are you using?

The bundled DataDirect Driver from webMethods?
This driver is only intended for webMethods internal functions like Auditing etc.

If you are using the JDBC Adapter you should use the corresponding drivers from Oracle and Microsoft, or you will have to buy a normal version of the DataDirect-Driver from DataDirect. If you have already your own copy of this driver check for a new version, maybe your old version causes conflicts with the version of the bundled driver.


I’m using both. DataDirect Driver (for webMethods Internal functions) and for the JDBC adapter (Oracle) I’m using Oracle JDBC driver version and the “oracle.jdbc.pool.OracleConnectionPoolDataSource” from classes12.jar.

Do SP2 provide a knew version of the DataDirect driver or is there anything else in SP2 that could causes this conflicts?


Hi Arild,

IS 6.1 SP2 uses DD Driver Version 3.3 Build 0069 (same as SP1)
Original IS 6.1 only provided Version 3.3 Build 0009.

But you can request a newer driver version (3.4 Build xxxx) from wM technical support.

But these jars provided by wM are not allowed to be used for JDBC Adapter.

If you are running your IS in Java 1.4 you should use the ojdbc14.jar instead of classess12.jar.

Newest Oracle Driver available at Oracle is

Can you post the complete configuration screen for the connection in doubt?


Thank you Holger for you response.

The problem is solved. When you install SP2 folder …\IntegrationServer\lib\entrust
and file
is deleted.

If you dont have this files in classpath from an other webMethods location the missing of the entrust-files will make the IS startup to fail. The missing of the .jar-file will give the error mention above. Additional the startup will log an error on startup of the JDBC pool-manager.

I solved the problem by copying the files back from …\ManagerServer\lib


Hi Arild,

sounds strange.

You should open a SR with support to check this.

Normally these files should not be removed but they might be updated during install.