JDBC Adapter. (85.02) in WebMethods Integration Server 10.11

JDBC Adapter

I am getting the below error while creating the JDBC Adapter. (85.02) in WebMethods Integration Server

  1. [ART.118.5011] Adapter Runtime (Connection): Unable to create new connection JDBCConnection:jdbc_localTransaction.
  2. [ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
  3. IO Error: The Network Adapter could not establish the connection

I am working with Oracle 19C as database with below details,


|Product|Integration Server|
|Version|10.11.0.0|

Java version 11.0.13 (55.0)
Java VM name OpenJDK 64-Bit Server VM
Java build info 11.0.13+8-LTS, mixed mode

Jar file with which i have tested are. Ojdbc5,6,8,10 and 14, along with server restart each time, But i am still getting the same error.

Requesting assist.

Thanks & regards
Himanshu Ghanekar

It looks like you have a typo in the “Server Name”. Please correct it and try again.

Hi,
Thanks for the reply,Sorry, its the Wrong screen grab, I corrected it already. Still the same error.

.Also i am connecting via Service name and not SID, if this helps to point the issue.

Instead of database name under other properties pass driverType=thin;ServiceName=<Your ServiceName>

Hi,

DatabaseName refers to the SID and not the ServiceName.
Regarding driver jar: ojdbc10.jar should be fine for Java 11 and above.
ojdbc14.jar is fairly old, it was referring to Java 1.4.
All other jars indicate the major Java version for which they were originally built and are working with this Java version and all newer ones.

Which version of JDBC Adapter are you using?
Were the fixes applied for the JDBC Adapter?

Restarting IS is not required when placing the jar in the packages/WmJDBCAdapter/code/jars folder of the instance.
In this case a simple reload of the WmJDBCAdapter package is sufficient.
Can you provide the version of the driver jar?
This info can be found in the META-INF/MANIFEST.MF included in the jar.

Regards,
Holger

Hi,

Thanks for the reply, but did not work.
Error Changed though.
[ART.118.5011] Adapter Runtime (Connection): Unable to create new connection JDBCConnection:jdbc_localTransaction.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
ORA-28040: No matching authentication protocol

Hi,
Thanks for the help,
Below are the details from MANIFEST.MF
Display-Fix-Name: MAT_10.11_Server_Fix1
Release-Date: 12/15/2021
Require-SUM-Build: 11.0.0.0001-0006
Require-Fix:
Fix-Version: 10.11.0.0001-0003
Require-Product: wMProduct.MFT;version=10.11.0
Created-By: 1.8.0_151-b12 (Oracle Corporation)
Affected-Products:
Manifest-Version: 1.0
Empower-Fix-Id: MAT_10.11_Server_Fix1
Ant-Version: Apache Ant 1.9.7
Fix-Name: wMFix.MFTServer
Require-Product-Codes: MAT
Require-Platform:
Display-Group-Name: ActiveTransfer.

Thanks and Regards

May I know the version of the jar file you are using?

Hi,

This one sounds more like an issue with your database and should be checked with your DBA.

Is only the connection for the JDBC Adapter not working, or is the JDBC pool alias failing too?

Regards,
Holger

Hi,

this is the version of Active Transfer Fix jar.

I was asking for the information of the ojdbc.jar.
Ramakrishna is also referring to this information.

Regards,
Holger

Hi,

pool alias is connecting fine. Double checked.
Where can i find the information abt ojdbc.jar, i am new to webmethods, just started with it,
so please dont mind the newb questions.

thanks & regards

Hi Ramakrishna,

i tried with all the ojdbc.jar, starting with 5,6,7,8,10 and 14.
Is there anything else u require?
please dont mind the questions, new to Webmethods here.

Thansk for the help

Hi,

when it comes to webMethods 10.11, using ojdbc10.jar is recommended.
You can open the ojdbc10.jar with any zip tool and you will find a META-INF/MANIFEST.MF in it, beside some other directories which contain the classes for the driver and the data source connector.

From where did you obtain these ojdbc-jars ?
I would recommend to download them the Oracle website (JDBC and UCP Downloads page).
Requires a free registration.
Latest version available is Driver 21c (21.6.0.0.1) coming as either ojdbc8.jar or ojdbc11.jar.
Both variants can be used with wM 10.11, but in this case I would prefer using the ojdbc11.jar.
The Oracle site currently lists driver versions from Oracle 18c up to 21c, consisting of ojdbc8.jar (for all versions listed), ojdbc10.jar (Oracle 19c) or ojdbc11.jar (Oracle 21c).

Additionally make sure that there is only one ojdbc.jar under the instance-directory tree of your IS, ideally under the packages/WmJDBCAdapter/code/jars directory as mentioned above.

I checked the error code you have mentioned above (ORA-28040: No matching authentication protocol) on Google and it is indicating that there is a jar with Oracle version 10 or older being used.
ojdbc14.jar, ojdbc5.jar, ojdbc6.jar and ojdbc7.jar are considered EOL as long as there is no need to use such old jars.
ojdbc8.jar for Oracle Versions below 12c should be also considered outdated as they do not implement latest JDBC 4.x specs.

Regards,
Holger

1 Like

Hi @Holger_von_Thomsen, @Ramakrishna_Chandragiri

This worked, i removed all the jars(leaving OJDBC10 as suggested) and passed service name in other properties as suggested by @Ramakrishna_Chandragiri.

I guess both solutions worked together. Thanks a ton for the help.

Have a greate day.
Thanks & regards
Himanshu Ghanekar