Java Service /Patch not deploying properly

Hi All,

I have a Folder A
Java Service 1
Java Service 2
Java Service 3
Java Service 4(Just Created Newly and would like to deploy in upper environments as a patch deployment)

After the patch(JAVA SERVICE 4) deployment i tested in upper environment But could not see the results what i am expecting,

My question here is is it mandatorY to deploy the whole/full package,

My IS Environment

IS_6-1_SP2

Thanks
Dandi

As you may have suspected, the answer is no, it is not mandatory to deploy the whole/full package. That’s why the patch facility is provided.

To figure out what is going on, perhaps you can elaborate on “could not see the results what i am expecting.” What results are you expecting? What results are you actually seeing?

Rob

I tried patch deployment couple of times but it did not work,So i tried with the full package deployment its working fine now,

Not sure what was causing the issue when i did a patch deployment,

Thanks
Dandi

I suspect that the patch deployment was impacted by how Java services are compiled and managed.

Hi Dandi,

Single java services can be very well deployed using webMethods deployer. You can simulate the deployment before doing the actual deployment and see the results, if there are any warnngs. After the deployment you can check the log, this will show if any errors encountered in the deployment.

Thanks,
Arjun

Dandi didn’t mention that Deployer was being used. I assumed, perhaps mistakenly, that IS Administrator was being used to create and install the patch release.

Sorry for the late reply .I did used the Webmethods 6.5 deployer,