java.lang.reflect.InvocationTargetException: Link Error occures occasionally.

Hello
I am trying to play with some basic integration with TFS using microsoft library stored here:
\opt\esb\IntegrationServer\packages\OriTfs\code\jars\com.microsoft.tfs.sdk-11.0.0.jar

I’ve included this line
JAVA_OPTS="${JAVA_OPTS} -Dcom.microsoft.tfs.jni.native.base-directory=/opt/esb/TFS/native"
into
\opt\esb\IntegrationServer\bin\server.sh

It works for some time (also references are visible in java service) but after couple of invocations (check in/check out to tfs) I get this error:

Libraries become clearly unseen in my java service…

I tried many things to do or search for, but I always end up in shutdown/startup of IS.

Can someone please help me?

the jar I use is here:
http://dratenesperky.cz/tmp/com.microsoft.tfs.sdk-11.0.0.jar

I am unsure that whether webMethods support TFS for version control.

They don’t - and that is the reason why I’m trying to use this library by myself. If it’s Microsoft TFS or any other library is not important at all.
Point is, that I have a library that works just fine, but IS (or designer) is somehow not able to keep it loaded.
I could see some similar posts here with the same issue for other libraries, but all the hints were just leading to something I’ve already done…

I have never tried this stuff… :frowning:

Could you attach the com.microsoft.tfs.sdk-11.0.0.jar?