Java exception running a command line

I’m following the guide for implementing OpenPGP using GnuPG.

when I run the listKeys service, it gives me this:

com.wm.app.b2b.server.ServiceException: I/O Exception running command: java.io.IOException: CreateProcess: gpg --homedir e:\webMethods6\IntegrationServer\gnupg --no-tty --list-keys error=2

but when I run that some command (gpg --homedir e:\webMethods6\IntegrationServer\gnupg --no-tty --list-keys) in the command line, it runs fine…

what does that error=2 mean? where can I find it?

thanks.

found out what I had done, not sure if this is what error 2 means or not.

the command I was running was ‘gpg --homedir…’ which worked find in a command window, because I had included the proper directory to the gpg executable in the PATH environment variable.

but, when webmethods IS was started, that directory wasn’t in the PATH variable, so the webmethods IS server didn’t recognize the ‘gpg’ command. when I went into the OpenPGP properties file and changed the command setting to be the fully qualified path to the executable’s directory, it worked fine.