Java compile issue

Hi. I’ve been working with IS 4.6 and Developer for some time now, but this is the first time I’ve ever required a Java service, so I’m having some troubles getting it going.

Specifically, I needed to make use of the unicode “toChar” service that I found on wmUsers ( http://www.wmusers.com/wmusers/messages/117/186.shtml ) in order to specify segment delimiters. When I copy/paste the code into a new java service, then save it, I get an error:

usr/local/opt/webMethods/IntegrationServer4/packages/PCS/code/source/EDI/util/lookup/JavaService.java:14: Superclass java.lang.Object of class EDI.util.lookup.JavaService not found.
public final class JavaService

I’ve tried moving the service around, and changing the name, all kinds of things. So, then just for a lark, I tried to recompile a java service that is delivered with IS 4.6 - I get a similar error, though this time it also had an import error. I tried to build sample.commandLineExec:fireCommandExec in the wmSamples package - here’s the errors that are generated:

/usr/local/opt/webMethods/IntegrationServer4/packages/WmSamples/code/source/sample/commandLineExec.java:12: Package java.io not found in import.
import java.io.*;
^
/usr/local/opt/webMethods/IntegrationServer4/packages/WmSamples/code/source/sample/commandLineExec.java:15: Superclass java.lang.Object of class sample.commandLineExec not found.
public final class commandLineExec
^
2 errors

I’m sure it’s just a setup issue, but I don’t know enough about java/webMethods to fix it on my own.

Thanks in advance!

Hi Greg,

Try this

http://www.wmusers.com/wmusers/messages/117/15196.shtml?1055519538

cheers
bruno

Thanks. I’d read that thread, and wasn’t sure if it was my problem.

I went and had a look at my server.cnf, and it doesn’t even have the watt.server.compile defined in it! I’m a little leery of changing the server.cnf though, because we’ve been having problems where the IS loses it’s license key somewhat spontaneously :confused:

I think proper procedure is to

  1. shut down IS
  2. change server.cnf
  3. start IS up again

but I want to make sure before I do anything.

Gre,

yes absolutly right steps,before adding or modifying any parameter in server.cnf file just shut down IS and start up again,so that it will re-initialize all its settings…

Add java classpath on you client machine or point the java.exe in the server class path.

And there are many threads which has answered same problems.

HTH.

sorry i mis-spelled your name.

Greg.