Issues Getting wM to work with its IS and TN database

Hi. I am installing webMethods 8 64-bit from scratch and I am having issues getting the TN database working. I have a couple issues that I would appreciate any help. :frowning:

Issue 1:
I reinstalled wM Integration Server using the embedded database for IS and pointing the TN to the path of an external (and empty) SQL 2005 database. I made sure I copied the file “sqljdbc4” to the “IntegrationServer\lib\jars” folder so that wM does not throw the error “suitable driver not found”. The installation went fine except for many DB connection errors, which was expected because the TN database was blank.

After wM start is completed, I went to JDBC Pools from the web console and I successfully test the Pool alias. However, when I run the DB Configurator to populate TN database I get the error:

Database Connection error: No suitable driver found for jdbc:sqlserver://;databaseName=TNPOC_v8;SelectMethod=direct;SendStringParametersAsUnicode=false

I copied the file “sqljdbc4” in any jar or lib folder I could find but to no avail.:eek:

Issue 2:
I then decided to run the scripts manually instead. So I connected to the DB using Management Studio and attempted to run the 3 scripts in the folder “common\db\scripts\mssql\tradingnetworks\31\create”. They are “mss_tns_c_ddl”; “mss_tns_c_dml”; and “mss_tns_c_dml_tracking”.

The first script went fine; the 2nd did go ahead but threw a warning about a size of a something (a table I think). The 3rd threw the error “Invalid object name ‘COMPONENT_EVENT’
I decided to ignore the error and take my chances, so I started wM and most things went fine except for the following errors which seem to be inter-related:

2010-08-18 23:21:19 NZST [ISS.0137.0006E] Scheduler: Error initializing scheduler: Invalid object name ‘IS_USER_TASKS’

2010-08-18 23:21:20 NZST [WmAuditingSC.destination.1122E] Destination ‘SessionDBDest’ caught unexpected Throwable logging audit event: Invalid object name ‘WMSESSION’

2010-08-18 23:21:21 NZST [WmAuditingSC.destination.1122E] Destination ‘ErrorDBDest’ caught unexpected Throwable logging audit event: Invalid object name ‘WMERROR’.
Search of information on what these objects could be suggested these are tables that should have been created. However, I can’t find them in the TN database, and I thought I use IS’s embedded database so I don’t have to worry about it, so I have no idea where it is supposed to reside. Furthermore, I could not even find these tables in the databases of wM6.5 that we use at present. So I have no idea where these table should be and how to get wM to not throw the errors.

Can anyone please help me fix any of these issues so I can get wM to work fine with its databases?:confused:

Try to run DB configurator without passing additional parameter, just jdbc:sqlserver://hostname:port;databaseName=dbname … should be fine…

These all tables in IS Core Audit (WmSession and WMError) and IS Internal (IS Tasks) Database components … so check DB schema if you have install these db components…


Thanks for your feedback. I fixed both issues:cool::

Issue 1: The problem was in the URL. wM6.5 and wM8 seem to have a slightly (thus unnoticeable) difference in the construction of their URL :confused:. Our URL in wM6.5 is:


The URL in wM8 had to be:


the wM6.5 URL seems to work inside JDBC Pool but not with the configurator . As soon as I have added the “wM:” the configurator worked fine.:proud:

Issue 2: Through reading the installation documentation I had the impression wM would have created all its needed schema by itself becasue I opted for the “embedded database”. I did not realise that I had to run the configurator for the IS Internal databases (and any other database for that matter). Obviously I was wrong :lame: and as soon as I have run the configurator to create the schema I got rid of the errors and I had a happier system.:smiley:

Again, thanks for your help.