issue with provider webservice with xmltags

I have provider webservice with xmlstring as input .

Now when i pass the value inside xml tags “<” and “>” ,it is not being picked up by IS .
say my sample xmlinput was


Now when i replace the tags “<” as < and “>” as > as shown below ,the xml input is picked up y IS.

ABC So is there any way where we can pass the xml with out the replacing the tags in webservices ?

Set your encoding option to true… You dont have to manually replace the <, > symbols with its corresponding values. It will be taken care internally.

i tried setting encoding to UTF-8 in SOAP UI while passing the request ,but of no help as i get the below error message
“Document/Literal Coder: decoding error; cant convert SOAP Message to IS Document”

Is there any way to set encoding in IS for provider webservice or in WSD created from it ?

Hello Pran,

Try to put your xmlstring in between CDATA and then call your webservice.

ohh… i thought you are trying to send xmlstring from one IS to another IS, hence suggested option of setting the encoding to true while converting IS document to a xml string… your problem is even before that where you need to pass data from external system… add a header in ‘headers’ tab.

Name of header- Content-Type
Value- text/xml; charset=utf-8

Give it a shot…


Hey tht just did the job .

Putting the msg in CDATA
Thanks Sourabh

Thanks for your suggestion
Can you please provide me an example for these headers?
anyways my issue with soapui is resolved with CDATA section
this is just for info