Issue with Looping when using XMLNodeToDocument

I seem to be facing a weird issue with the loop step I am trying to execute. I am receiving an XML doc which I convert to a local doc in IS using XMLNodeToDocument. Then I try to loop on one of the Document List inside that Document. The problem I am facing is that if the XML doc contains only one record, it skips the loop step and goes on to the next step. However, if the XML doc contains more than one record, then the loop step executes. I tried testing the document itself separately by providing values manually and in that case even if there is one record, it still loops through it. However it is only when I map the XML document to the IS doc that the loop does not execute.

Has anyone seen a similar behavior in the past? Are there any known limitations? Or is there some proper tag that the XML format should specify before sending the document records? I am using wM 6.0.

Thanks in Advance for your help.


Hello Anant:
In the input parameters for XMLNodeToDocument, set the value of array to the element you would like to make into an array regardless of whether it appears multiple times in the node.
Thanks, Sue G.

Thanks Sue, That was awesome! It worked.


It also works by setting the documentTypeName input to the fully qualified name of your document in IS. In a way, this is better than setting the arrays, because you could run into some errors if ever you change your structure by adding or removing loops.