[ISS.0088.9155] this SOAPMessage does not contain a valid Envelope object


I have a WSDL that I used to create both provider and consumer wsd.
Then, I tried to call the webservice in the provider side using the connectors on the consumer side. (I do this usually with my WS to test).
This time I got [ISS.0088.9155] this SOAPMessage does not contain a valid Envelope object error message when I try to make a call and I have no idea how can I debug and correct this problem.
I am using IS 7.1.2, with IS_7.1.2_WebSvcsXML_Fix17 and IS_7.1.2_Core_Fix23.

As I said, I never had this problem before, using the same manipulation.

The web service is working very well when I use soapUI. This make me thing that the problem is coming from the soapClient service.

It is very urgent. Can any one help?

Thank you very much

Increase the soap logging (on IS admin page, Setting->Logging->IntegrationServer->SOAP) and capture the soap request and response from Server Log. Then use the request captured from server log in soapUI and check whether you are getting response or not?


I am going to try this and let you know…

Well, the SOAP message I captured has an empty body. However, with soapUI, I used the same message to call the WS and it worked.
Does this make any sense to one of you?

I got some information.
I am exposing a web service and trying to call it from the developer. When I use the HTTP protocol to call the web service, it does work. But when I change it to HTTPS I got the error above.

I do the same thing with another web service and I it worked.

Why I am getting such a problem when I use HTTPS protocol with this WSC especially?

I too face the same issue. Came across the below suggestion from Empower but not sure if this applies.


Any suggestions?