[ISC.0064.9314] Authorization Required: [ISS.0084.9004] Access Denied


I’ve created a custom SOAP-MSG listener which has a custom Execute ACL, named “SOAP_Processor”. I have created a user, “LVKUser”, which is a part of this ACL. Calling SOAP-MSG webservices through this listener, authenticating with user “LVKUser”, works fine when calling from clients such as .NET and SOAPStation (SOAPStation used as a proxy webservice manager).
But I ran into a problem yesterday when trying to use webMethods itself to call these services. I use the Web Service Connector to create a client flow. When running the flow, setting user as “LVKUser” I get the following exception: [ISC.0064.9314] Authorization Required: [ISS.0084.9004] Access Denied.
When looking at the Session log the User ID is always “Default”.

If I use SOAPStation as a proxy between, everything works fine. Looking at the Session log after connecting with SOAPStation I see User ID “Default” and after that on the same second, User ID “LVKUser”.

Is this a bug in flow pub.client:http? It seems to me that it doesn’t send the username and password in this case.

When I do the same with a custom RPC webservice listener, everything works fine using client flow pub.client:soapRPC.

The webMethods server is version 6.1 with the following updates:


Java VersionwriteTD(“rowdata-l”); 1.4.2 (48.0)

I’ve tried this on two other webMethods servers with the same result.


goto the IS admin page and goto Package Management. Click on the WmWin32 package and run the reg service under the win32.ntlm folder.

This issue is caused because the service that you are trying to call is hosted on a windows server which uses NTLM Response to authenticate users. If your IS is hosted on UNIX then you have to write a java service for that. Google NTLM reponse with UNIX for more details.

Net Civilian


I have created WS connector , when i tried to execute the service by calling the connector it thrwoes the soap fault body error message as below even though i have given the anonymous as the ACL for all the list, read, write and execute
[ISC.0064.9314] Authorization Required: [ISS.0084.9004] Access Denied

Please let me know if any one have come across this kind of error.

Who provided you the WSDL file? Can you check with them about the issue.