[ISC.0050.0019V2] Copy failed: No source data available

Hi.
I’m using a flow service which contain a Custom SQL adapter service, which call our oracle database to get the count of Hits got to webmethods for a particular Request type for that Current day and time. The Flow and the adapter service work fine until 5:00 pm in the evening, but after that the adapter service returns No results under its output document list. when i ran taht custom sql directly in the database ( under SQL +) it yields results. But when I ran it from webmethods nothing. when I checked the server Log, following was recorded

[ISC.0050.0019V2] Copy failed: No source data available.

This is same case every day.

Can any one shed some light what exactly happening.
We are using webmethods 6.5 and oracle 10g

One scenario to think of is, your IS and Oracle servers are running on different timezones with IS advanced than Oracle and if your query is using any datetimestamp fed from the IS in which case 5PM(IS) becomes a future date in Oracle. Please post the query/inputs, it may give somemore insight for others to help you.

Do you have any copy condition defined in your code. This error is logged if any copy condition fails(evaluate to false).

Following is my Adapter Connection details
Transaction Type NO_TRANSACTION
DataSource Class oracle.jdbc.pool.OracleDataSource
serverName: XX
user XXXXXX
password ******
databaseName : XXXXXX
portNumber 1591
networkProtocol
Other Properties driverType=thin
Enable Connection Pooling true
Minimum Pool Size 1
Maximum Pool Size 20
Pool Increment Size 1
Block Timeout (msec) 1000
Expire Timeout (msec) 1000
Startup Retry Count 0
Startup Backoff Timeout (sec) 10

and as per the query select count(*) cnt
from rqst_trck_info r where
r.last_updated > to_date(TO_CHAR(current_date,‘DD-MON-YYYY’))
group by r.rqst_type,r.corporation,r.product_cmpny,r.booking_cmpny

This Query work stops working from webmethods adapter service but work directly in the database.
Database version we are using is Oracle 10g

Why are you using r.last_updated > to_date(TO_CHAR(current_date,‘DD-MON-YYYY’)) ?

Is there any difference in data type of last_updated and current date ?

If yes, you should use r.last_updated > to_date(TO_CHAR(r.current_date,‘DD-MON-YYYY’))
and If not, You should use r.last_updated > r.current_date .