IS 7.1.2 - Scheduler: Unable to get cluster members

Hello everybody,

another day, another strange error on our customer’s production environment :frowning:

After restarting Integration-Server this morning they have consistent errors in the log with SQL-adapters not being able to establish a connection though the database is accessible.

Furthermore we see the following errors in the log:
2010-08-02 10:52:24 MEST [ISS.0137.0020E] Scheduler: Unable to get cluster members

My research in Advantage and Empower didn’t seem to find matching issues. There are only three articles including this error message in the first place:
https://advantage.webmethods.com/advantage?w=0&targChanId=knowledgebase&oid=1614333247

https://advantage.webmethods.com/advantage?w=0&targChanId=knowledgebase&oid=1614326015

and

https://advantage.webmethods.com/advantage?w=0&targChanId=knowledgebase&oid=1614325967

Furthermore they only describe symptoms and a possible resolution but no reason for what is happening. Thus none of them seems to make sense in our situation.

My question: What is the actual cause for this error, and can it be related to the problem with the database connections? I was just guessing network problems but the above stated articles do not mention anything like that.

Thanks for your help,

Sascha

You have a clustered environment, for which when configuring scheduled task you can select to run in “all”, “any” or a particular node.

I don’t know which option you have selected but the scheduled task is unable to get the members for the cluster.

Ensure you are at latest fix level for “Core” fix, I think current is 7.1.2_Core_Fix26.

If problem remains with latest fix contact wM support.

Hi DevNull43,

thank you for your reply.

Where would I see the selected settings “all”, “any” or “node name”? I think that our client does not run IS in a clustered environment.

The attachment to this post shows what the task’s properties look like.

Anyway, it still isn’t clear to me where and why a task would look for a cluster member and why it would possibly fail to get it.

Unfortunately we cannot install an IS-Core-fix later than version 14 as already version 16 has several dependencies to other fixes, one of which significantly changes XML communication, which would force us to comprehensively re-write large portions of our application. :frowning:

Cheers,
Sascha
pic09514b.jpg

The option to select target node is only enabled when clustered.

If you are not clustered and get that message, indicates a clear bug.

If you have any issue with XML after Fix16, you would need to contact support and clarify situation, as not been able to install latest fix or SP would be an issue today, or tomorrow, and from your error looks like you have already one.

I had this problem.
I fixed it by clicking on the scheduler name , dont change anything , click update task and then try to enable scheduler.
Worked for me.
-Scooby

Hi Guys,

I was also facing the similar issue.
It got resolved after clicking on the scheduler and updating it.

I have found the root cause for it.
It happened because the IS name got changed.

e.g. initially scheduler was created on IS1 but now it got changed to ISDev then scheduler will not be enabled unless it is updated.

Thanks,
Amit

YES you are on the right direction,Amit:

The option to select target node is only enabled when clustered.

If you are not clustered and get that message, indicates a clear bug.

GOdaddy Domain

This issue is been faced normally when host entry of servers (machine) is modified…Integration server picks these value automatically…but scheduler saves the info in Db at the time of creation.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.