IS 6.0.1 and MQ Adapter 3.0 SP 3

Has anyone tried applying MQ Adapter 3.0 SP3 to his or her 6.0.1 IS? Before I applied SP3 the MQ adapter was working just fine (no other SPs or FIXs had been applied). After I applied SP3 I can execute my request/reply message handler only once. The second time I execute the request/reply message handler everything locks up.

In addition, there are differences in the MsgHeaders of the generated request/reply message handler and the runtime requestReply. Specifically, the MsgType field in the generated message handler will only accept values of 1, 2, 4 and 8. However, I believe that the values should be a string such as “Request”, “Reply”, “Datagram” or “Report”.

Anyone�s experiences would be appreciated.

y experience is only on version 3 of the adaptor utilising SP2 and the 4 fixes. I am running MQ 5.3 on Windows 2000. I have just tested some handlers after applying SP3. (SP3 seems to incorporate the earlier SP2 and its associated interim fixes).

  • Listen handler works ok
  • Both Request/Reply and Put handlers cause the Integration Server to crash and
    core dump. You get one of those charming Windows messages e.g.
    “The instruction at “0x7150767a” referenced memory at 0x00000008.
    The memory could not be read.”
  • Get works ok

Sounds like a similair experience… anyone else???

PS: My question is what is an appropriate rate to charge as a bug finder?

I have the same experience too.

In a flow service, I invoke a MQ message handler inside a loop, and it works fine just one time.
at the second time it goes in error.
the error message is a java Null pointer exception, so we cannot understand what happens.
in the websphere MQ adapter LOG, there is no trace about that error. so it seems that the problem at the IS level.

I had the same problem too.

I have solved it re-installing all MQ parts.

here a short list of what I have done:
j2ee (v 1.3.1)
MQ java classes (v 5.3)
IBM support pack MSOB
Mq adapter 3.0
copy mqjbndXX.dll file

now it works.

We are using MQ Adapter 3.0. We found both GET and LISTEN message handler behave like this:

Even the queue is empty, both GET and LISTEN message handler are return a message document with messagebody filled with none recongonized characters.

Is there anyone else have the similar experience? We assume the LISTEN message handler will only invoke the sevice whenever it ditect there is a message. Now we noticed that even the queue is empty, the service is keeping got invoked at a rate a dozen time per second. It is strange?

We had the listener invoking our msg service every “poll” as well. The resolution was to make sure the properties files were available in lib/classes. Apparently the exception raised when the properties were not found caused the listener to get confused and invoke the msg service.

I think you’ll want to make sure you have the right mqjbndXX.dll too, where XX varies depending upon which MQ client jars you’re using.

As for the invoking your msg service a dozen times per second, this would seem to be related to the “Shutdown Interval”. I don’t know for sure, but I think this config parm is misnamed. It appears to be the timeout interval that the listener uses for each get that it does. What is the value you have set for this?

Hi Guys,
I am having he same problem of replyReply service locking up on the second run after applying the SP3( i hadn’t applied any fix or SP(s) earlier).

My configuration is as follows:

MQ Series classes - v5.2.2
MSOB is copied as mentioned in the Adapter3.0 Installation doc
MQ Adapter 3.0
mqjbnd04.dll ->> is this the right version to use. I also have a mqjbnd01.dll with me

SP3 has been applied (this is the only thing i did yesterday).

Am i supposed to include/configure any more files??? Any help is greatly appriciated on the procedure of running requestReply with SP3.

Thanks in advance…

Hi Guys,

After after doing some research and checking up with webMethods CustomerService, they told me to set the "releaseConnection" parameter (one of the input parameters for the Handler) to "Yes".

Now requestReply works fine in the loop.


We are experiencing a similar problem with requestReply in a Solaris environment. I have installed:

MQ Adapter 3.0
Fixes 6-12

We do not have a complete MQ client 5.3 install on the box, but I copied the and files into the IntegrationServer\lib\jars directory. Do I need to put more files there? From what I understand in the 5.3 client the mqji*.properties files are in the jars.