IS 46 and JDBC Connection Pooling

I have seen these stacktraces. In my case they began when a new database alias was created to a SQLServer 2000 database. The alias did not include any of Min. Connections, Max. Connections or Expiration Time. The stacktraces were being generated each time the application did a pub.db:execSQL. This usually resulted in several stacktraces being generated. Once I specified the missing connection pooling parameters, these stacktraces stopped. In your post you indicate that you have settings for Max and Min, but timeout is not mentioned. If the timeout parameter is not specified add it and see if the problem goes away. It did for me.

Thanks John…

You’re right, I see a connection pool parameter called “Expiration Time (ms)” which I left blank, since the documentation mentions that the default is 60000, but I guess I have to specify it explicitly!.. we’ll see if this solves the problem…

I’ve experienced the same problem and explicitely setting the value solved my problem. Seems the default value is not accurate.

We have JDBC adapter configured and working fine. But last twodays we are getting the following exception.

[ART.118.5053] Adapter Runtime (Connection): Unable to get a connection to resource jdbcConn:myConnection.The pool doesn’t have a connection available for the request.

Min Pool size = 1, Max pool size=150 and Expiration Timeout = 3000.

Any one help me to find out the issue ?



Re-Load any package that is dependent on the JDBC adapter in question, though the admin tool.

That solved the same issue I had with adapters.