IS 4.6 and JDBC Driver for Oracle 8i on Windows 2000

I’m trying to configure an Integration Server 4.6 Database Alias, but not being a JDBC user I can’t locate the Oracle JDBC Driver. I’ve installed Oracle 8.1.7 and successfully tested the Oracle JDBC Driver for it using the JdbcCheckup.class provided by Oracle. According to the info I have, I thought that the driver was located in the jdbc\lib\ (or file since it must be in the CLASSPATH variable. And according to the IS 4 documentation, I can use a JDBC driver by copying the zip classes file to the IntergrationServer4\lib\jars directory. But IS can’t seem to locate the Oracle JDBC driver. I thought the name of the driver was oracle.jdbc.driver.class, but that class is not in the zip files and doesn’t seem to exist on the system. Any help would be appreciated.

Well, I gave up on the Oracle JDBC Driver. Since no one responded I guess no one else really cares. Instead I went with the default Driver included with Integration Server 4.6. Namely sun.jdbc.odbc.JdbcOdbcDriver with a DB URL of jdbc:odbc:MYDSN (where MYDSN is a System Data Source Name created via the W2K Control Panel/Administrative Tools/Data Sources (ODBC). If I ever stumble across the Oracle JDBC Driver and get it configured, I’ll post the info.

Sounds like you’ve moved on, but, for future reference, the name of the DB Driver (located in is:


Thanks, I tried that but with the same results.
I verified via the IS Server Adminstration Manager “Server>About” that “C:\IntegrationServer4\lib\classes” is in ClassPath. I verified that the oracle “” is in that directory. In the Alias Management I specified “jdbc:oracle:oci8:@sandbox” as the URL (sandbox is a valid database name) and “oracle.jdbc.driver.OracleDriver” as the driver and still I get the “Could not connect: No suitable driver” error message. IS4 is using a 1.3 Java environment. Could that be a problem with the 1.2 Java Oracle driver?

Thanks again!


Try extracting the file, to the same directory as where it is present. Just an idea, but have seen it work with the Oracle thin driver.

That was it - Thank you! The driver can be loaded, but still not used. Now I get the error message - Could not connect: Link Error: no ocijdbc9 (ocijdbc9.dll) in java.library.path

So once I figure where to put the dlls, I bet that will be the last piece.

Thanks again!


Got it! Some how I had gotten the 9i jbdc driver in the \IntegrationServer4\lib\classes directory and it was looking for some 9i dlls that I didn’t even have. So I deleted all the Oracle files under the \IntegrationServer4\lib\classes directory, copied the Oracle to it and unzipped it. Using oracle.jdbc.driver.OracleDriver as the driver name and jdbc:oracle:oci8:@database as the URL, I finally got it working.

Thanks again to those that provided advice!