Invalid white space character (0x8) in text to output

Hello Experts,

We have been facing the following error occurring intermittently in our Live environment. I have checked in Empower but couldn't find any reference to this error. 

errorDescription : Invalid white space character (0x8) in text to output (in xml 1.1, could output as a character entity),node=https://xxxxx.xxxx.co.uk:1234/soap,role=https://xxxxx.xxxx.co.uk:1234/soap

As an extra information about the message flow, the ESB service picks up the message from IBM MQ and does the validation and this is where the message seem to be failing. At the first instance we thought this could be an “encoding” issue and started analysing the XML (coming from the source application), but there was no discrepancy as such. Out of curiosity when we reprocessed the failed message from MWS, it failed again with the same error. However, when we extracted the pipeline XML and executed the service manually from the designer with it, the flow was successful.

Any help/suggestions to resolve this would be much appreciated.

Thanks

for xml 1.0, 0x8 is not a valid xml character
see here: https://en.wikipedia.org/wiki/Valid_characters_in_XML

when you extract pipeline XML, it worked. I guess WM pipeline saving code will filter out invalid character automatically.
check this link for filtering out invalid characters
http://blog.mark-mclaren.info/2007/02/invalid-xml-characters-when-valid-utf8_5873.html

Hello Tong,

Thank you so much for your reply and the link provided certainly helps. However, as per the example provided on the the link, it seems the XML is being stored in the DB and when the XML is retrieved that’s where the data is converted into Java objects this error occurs. But in my case, the error occurs at a run time (as soon as the message has been picked up from MQ and the XML validation process starts in ESB) and it’s very intermittent in nature(when I say intermittent, the last error was observed on the 22nd April). We can possibly think about including the Java code piece (as suggested by Mark) right before XML validation step, but just wanted to check if there could some other issue (related to SAG patches etc.).

As an extra information: We are currently on the SAG v 10.3 with IS_10.3_Core_Fix7.

Thanks

Hi Sandip,

Please keep this thread posted on what solution you have ended up or SAG tech outcome and it will certainly help other wM users!

Cheers!
RMG

I don’t think there should be a fix for such case.
invalid xml character won’t be accepted by any system.
your issue seems transient, that means the system who is generating such document has bugs.
If you can’t identify where is this originated and ask them to fix, it’s safe to add the filter at your inbound service.

Hello,

Sure thing! As mentioned in this thread earlier, since 22nd April we haven’t observed the error occurring. We think this could be to do with the patch implementation and since the our IS’s have been restarted, the errors have stopped. But, we are going to keep this under observation, and if the error resurfaces then we can possibly think of the filtering the “invalid characters” from the XML string by invoking the custom java service (as suggested by Tong). I will surely keep this thread updated with the decisions that we are going take to deal with this issue in future.

Thanks

@Tong: Thanks for your reply! We are going to keep this under observation as the error have stopped occurring since the past couple of days. In case the errors start occurring again, we will possibly think of fixing it using the Java service (as you had suggested earlier).

Thanks

OK I believe you are on the right path and hope the issue not pops up again even if there is also it sounds like you have possible some work around solution now!!

Cheers!
RMG