Integration Server fails to connect the SAP Failover box

Ray,

For your information,

The cluster is set to failover between two physical sites. The frontend subnets used are different at both sites (this is a network design principle). Therefore in order to mask the change of the IP address from the clients we are using GSLB (global server load balancing) to return the correct IP address for the SAP gateway. For this to work it is necessary that the application does not cache the IP address but instead does a DNS lookup each time it attempts to connect to the gateway. If it does this then GSLB will always supply the correct address and failover will be seamless. It is accepted that this will be slower than caching the IP address but we have accepted the performance hit given, that the impact is in fact minimal as far as the response times are concerned. This is not an issue with our other interfaces.

The configuration for webmethods seems to suggest that there are configuration parameters that would enable us to stop the IP address of the SAP gateway from being cached by the webmethods software. So the question from us, in the first instance, is why are the parameters not taking effect and why is the IP address being cached. So cluster design aside, if you could answer the question of why the webmethods software fails to use the new IP address it would be much appreciated.

Thanks in advance