Installation Error

Hello Everyone,

I have a problem in installing the trading networks on my local machine. I dont understand if iam making the mistake in giving the exact JDBC URL while installation.

This is the URL i give when installing the IS, TN, Broker. Dont know if i have to give the table name also here.

URL - jdbc:wm: oracle://localhost:1521;serviceName=orcl

orcl is the SID of Oracle Database

In the server logs i get this error:

[Oracle JDBC Driver][Oracle]ORA-00942: table or view does not exist


“ Trading Networks could not retrieve data from your database. Go to the JDBC Pools page in the Integration Server Administrator and make sure your database URL, user name, and password are set correctly. Also make sure you created the Trading Networks database tables as described in the webMethods Installation guide”

I tried to create using Database Component Configurator with the Database Componenent specifying “PRODUCT - Trading Networks” and the same url given above but here it get this error:

[Oracle JDBC Driver][Oracle]ORA-00959: tablespace ‘WEBMDATA’ does not exist

Can someone please tell me what mistakes i do while using Database Configurator and while specifying the jdbc url.


Did you run test the TNPool connection in the JDBC Pools page? Was it been successful?

Also did you run the provided db scripts correctly and login to db and check if the schema/TN tables got created?


You need to check create tables spaces while running the DB configurator( you should have DBA access)

also ur url string has a blank space wm: oracle

  • jdbc:wm: oracle://localhost:1521;serviceName=orcl

Yes i think its the problem with my running the scripts in Database Component Configurator. TN tables not created in db.

Attached is the configuration i provide in configurator, there should be some problem here. I have DBA Admin Access.

I get this error when i execute it.

"[COLOR=red]Scripts create

  •   Script(1): F:\webmethods71\common\db/scripts/oracle/storage/25/create/ora_str_c_ddl_tablespaces.sql
  •   Script(2): F:\webmethods71\common\db/scripts/oracle/storage/25/create/ora_str_c_ddl_user.sql

  • Executing script : F:\webmethods71\common\db/scripts/oracle/storage/25/create/ora_str_c_ddl_tablespaces.sql

Error [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-02097: parameter cannot be modified because specified value is invalid
ORA-01261: Parameter db_create_file_dest destination string cannot be translated
ORA-01263: Name given for file destination directory is invalid
OSD-04018: Unable to access the specified directory or device.
O/S-Error: (OS 3) The system cannot find the path specified.
ORA-06512: at line 10[/color]"

Thanks in advance and appreciate your reply.


Based on the error above i think it’s not able to find/access the directory or some file destination:


Can you check this first?


From the screenshot you present, you have selected the option to create tablespaces and database user.

For this purpose you should change:

1- JDBC url MUST contain sysLoginRole=sysdba IE:


2- Admin ID/password must be set to “sysdba” and whatever password you have.

3- Finally the tablespace directory must point to the PATH your Oracle tablespace directory has on the remote server IE:
c:\oracle\oradata\orcl .

Remember you can execute this utility remotelly, so pointing to the directory containing the scripts makes no sense for Oracle.


Hi Naveen,
Dev is right. Use different user for WM database instead of system. For example wm71 can be used as USER for WM database and password you can choose then in the Administrator section you have to give Admin user id it may be ‘system’ and table space directory can be default table space directory of oracle or any directory path you have to give. Do not give any sql file name.
It will work.

Thanks folks, it worked.

I could execute the scripts successfully. The problem was with the tablespace directory path. I found a strange problem later after fixing this error.

CDC ERROR Illegal group reference

I could browse thru the forum and found out that the above error was because i had special character ‘$’ in password field which was not letting me execute the script. Hopefully its been fixed in the later versions than 7.1.

Thanks again to all.


Try reloading WmTN package or bounce IS and then re-login to TNC.It should work as you have already tested the TN JDBC Pool.