Insert into DB error

I am trying to map some string values into a SQL 2000 DB. I am using the execSQL service to do the insert how it keeps erroring out with the following error message. There are two fields in the DB that are “money” datatypes. The $dbParameterTypes in the execSQL service is passing the values in as “varchar”. What other parameter types can I use so that these values go in properly?

Disallowed implicit conversion from data type nvarchar to data type money, table ‘dbo.tblInvoice’, column ‘InvoiceTotal’. Use the CONVERT function to run this query.

Set integer instead of varchar in $dbParameterTypes,since you are trying to insert money relates numeric datatype.


Thanks for your quick response. When I tried ‘integer’ the values went in null. However, it worked with “numeric” set as the datatype. Thanks for your help.

But according to documentation and my earlier work we successfully passed with ‘integer’ datatype.

Any way good to know various types though.


Hi Tony,
I am having a similar problem, numeric insertions always inserts null. I gave the paramtypea as numeric…

please help


Did you tried with “Integer” datatype as well?