Input problem with Date field

I have a field on a Page formatted as a Date (D). Automatically there is an Auto Popup calendar where one can choose a date.

However, for some reason one cannot manually enter a date (in the format YYYY-MM-DD), as displayed when selecting from the calendar.

As soon as one enters another character after YYYY, the field is cleared.

Whose popup calendar are you working with? Natural’s, Microsofts, homegrown?

Check your settings for the various Date parameters (e.g. DTFORM, DF).

steve

We are using the stock standard Natural popup calender (there seems to be two of them, one for a field declared as a Date, and another for the Date Control - they certainly look slightly different on the two controls).

The DBA’s inform me that neither the DTFORM , nor the DF parameters are set on either the mainframe or the NDV. They are assuming it will then be the default value.

What’s the datatype on the page ?

The field is declared as a DATE field.

When selecting a date from the PopUp calender, it appears in the field as YYYY-MM-DD. I’ve specified an Edit Mask (YYYY-MM-DD) on the field, but then one looses the Auto PoUp Calender.

The reason I don’t use the DATE control, is because there is no Display Property on that control (which a normal field has).

The default value for DF is S, which is YY-MM-DD. Do you actually get 4 characters before the field is cleared?

Bribe the DBAs with a Castle, always seems to work. Find out what the values are.

Read the writeup of the popup calendar to see what format it assumes.

steve

Steve

Thank you! Using the default format solves the issue. We will override that in the NDV and NWO to match the output format (YYYY-MM-DD).

I’m pleasantly surprised to see you have some knowledge about an essential part of South African culture :o

Cheers!

Werner

From 1990 to 2000 I averaged two trips a year of 2-3 weeks duration to South Africa to teach Natural. Since then I have been there sporadically (although in 2008 I made 5 trips for a total of 9 weeks).

I have more than knowledge re Castle; lots of first hand experience.

javascript:emoticon(’:D’)

:smiley:

steve

You can also specify the DTFORM parameter in the NWO.bat or NWO.sh file that is used to initiate the natural session.