Importing commons-codec-1.9.jar file to the Integration Server

I am trying to import a jar file (commons-codec-1.9.jar) to consume its services in a java service. I tried placing the jar file in the following paths:

The code does not compile when I save the java file. It is failing at the part where I am trying to use the Base64 class within the commons-codec-1.9.jar . I can see the class file specified under the sever class path in the admin page, so I am guessing that the jar file is loaded. I also tried to configure the build path using the project explorer view. The code itself does not show an error, but there is a failure message coming up when i make an edit to the code and save it. I am using version 9.0 of the Integration server. I have given the error message below:

64: error: cannot find symbol

 encryptedString = new Base64().encodeAsString(encryptedTextBytes);


  symbol:   method encodeAsString(byte[])

  location: class Base64

1 error

Also, if we are connecting remotely to the Integration Server, how do we configure the build path for the imported jar file since we do not have access to the server folder and when we try to add an external jar the Designer tries to do that from the local drive and not from the drives of the server.

Thanks in advance for your assistance.

What is your requirement, can you share the details?

IntegrationServer\packages<package_name>\code\jars is the correct place for included jars used in packages.

Is the error message coming from IS or from Designer? If you use Designer for writing Java services you must include used jars in the eclipse build path as well. If the IS you are using does not reside on your local PC this means you need a local copy of the jar.

I have placed the jar file in the path: IntegrationServer\packages<package_name>\code\jars path itself. I am trying to use the class - org.apache.commons.codec.binary.Base64 in this jar file. I am getting the given error after saving the java code after edit. I believe it is thrown from the server since I have set the build path and it shows no error while running also. But it does not produce the desired output.