impersonate error

Hi,

I’ve tried to use the impersonate portlet (/portlet/wm_impersonateuser), while logged as sysadmin, and now I’m having the error below.

How do I remove the impersonate feature?

com.webmethods.portal.bizPolicy.BizException: [POP.002.0005] Unable to locate command: authenticateUser
at com.webmethods.portal.bizPolicy.biz.impl.BizPolicy.getCommand(BizPolicy.java:46)
at com.webmethods.portal.bizPolicy.biz.dir.impl.DirSystemBizPolicy.authenticateUser(DirSystemBizPolicy.java:36)
at com.webmethods.portal.framework.session.handlers.Validate.authenticateUser(Validate.java:224)
at com.webmethods.portal.framework.session.handlers.Validate.handle(Validate.java:149)
at com.webmethods.portal.framework.session.SessionManager.handleSession(SessionManager.java:212)
at com.webmethods.portal.framework.dispatch.DispatchManager.initSession(DispatchManager.java:658)
at com.webmethods.portal.framework.dispatch.DispatchManager.handleDispatch(DispatchManager.java:334)
at com.webmethods.portal.framework.impl.PortalServlet.service(PortalServlet.java:273)

Thanks
Bruno

The fact that the “authenticateUser” command can’t be found is a bit disturbing. Have you deployed or undeployed any other portlets recently? Maybe the wm_lockdown?

I’m not sure how you were using the Impersonate Portlet or how that could’ve generated the problem you are seeing though.

Hi Mark,

Yes, I did install the wm_lockdown at the same time as the wm_impersonateuser.
Can’t they both be deployed at the same time?

Bruno

The lockdown portlet overrides the default AuthenticateUser command. When uninstalling, it should restore the original command, but it looks like it didn’t.

What you’ll need to do is to re-install the core command. The best way to do that is the following:

  • Get a local copy of the phaseProvider.xml with mws getconfig phaseProvider.xml
  • Open that file and add the folowing code at the end (Just before the ):

<Phase name="RenableCommands" enabled="true" class="com.webmethods.portal.system.init.impl.DefaultPhase">
<PhaseInfo name="syncCoreConfigs" enabled="true" class="com.webmethods.portal.bizPolicy.impl.AutoInstallCoreComponents" />
</Phase>
  • Restart MWS

At the end of the restart, the AuthenticateUser command should get reinstalled. You should then delete the phaseProvider.xml (Don’t commit back to the database).

Please let me know how this goes,
–mark

Hi,

Thanks for the quick reply.
This was a production issue, and so, we decided to restore a database and file system backup which solved the issue.
Now, I’ve tried to reproduce the issue in development with no success.
wm_impersonateuser and wm_lockdown are both working fine in development.

Cheers,
Bruno