ILA adapter stops processing documents/events?

We are using the ILA adapter to invoke java objects based on events/documents it subscribes to. We have noticed that after processing 150-200 events, it just stops processing and there is no trace or log anywhere why it does that? We have also tried multi-threading to no avail?

Has anyone come across this? PLEASE HELP! This is a showstopper for us.

Have you tried running the adapter in debug mode while it is processing the events? You may see an error that is occurring that is not being reported back to the broker via Adapter::errorNotify causing the adapter to stop responding. Also, check the system logs to see if there is something being logged by the adapter process. Depending on where your adapter is running (x86 or Unix) will determine where your logging is going. Try those things and if you still have problems, then you will have to give more detailed info on what your event lifecycle looks like for this adapter and its component.