I always have the "Full authentication is required to access this resource" when posting a request

PRINCIPAL: 1016.0.259
UI: 1016.0.259


I have been trying to use the Cumulocity API but i always encounter the same problem :

“error”: “security/Unauthorized”,
“message”: “Full authentication is required to access this resource”,
“info”: " unavailable link"
my tenant id is : env658352 and my auth is in this form : base64 encoded tenant/username:password
i also tried base64 encoded username:password

edit : the tenant/username:password are from another user that i created because i couldn’t do it with the primary account as it is “managed through your authorization server”

What url are you accessing?


Can you do GET https://env658352.eu-latest.cumulocity.com/devicecontrol/newDeviceRequests?

No it still give me the same error whatever request i make

1 Like

It is possible. Can you double check the credentials and url?

I just checked following your method and it seems like my auth is at fault, could it my base64 encoding ?

It could be. Why not just enter plain text in the Username and Password fields in Postman?

1 Like

Just some notes:

  • Easiest would be indeed to use Postmans User/Pass Fields
  • When not using that, make sure you are using as Authentication Header “Authorization: Basic {base64 encoded tenant/user:password}”. I see you did not set the "Basic " in front of your base64-auth above
  • Is the tenant using SSO? If yes, note that your SSO User/Pass won’t work with Postman.
1 Like


The cause of my problem was like you said that i didn’t put the "Basic " in front of my base64-auth

Thank you !

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.