How to rollbacke the sap adapter form 7.1 to 6.5 version

HI,

I NEAD INFOR MATION ABOUT HOW TO ROLLBACK THE SAP ADAPTER FORM 7.1 version TO 6.5 version IN webMethods…please give me brief information in urgent…

Thanks in advance…

Please check the SAP Adapter documentation regarding uninstall and also backup all the SAP related packages/config files/.trc etc…

HTH,
RMG

Hi sir,

I have the backup of IS.Current Sap adapter package is not working fine like In the Adapter servervice creation time it throws error.we have check the all the possiblties to solve this issue.Finally we need to restore the backup Sap Adapter from the previous IS in the place of current package.can i know the pross:

I believe you should open an incident with SAG support:

Hi rmg,

when i am creating the sap adapter service i am getting folling error.can u please provide the info what should i check:

Failed to create the adapter service.
com.webmethods.developer.adapter.metadata.AdapterMetadataException:com.wm.app.b2b.server.serviceEception:[ART.114.243]Adapter Rntime(metadata):Failed to run resourceDomainLookupValues service.Details provieded in error log.
[SAP.101.9055]WmSAP Adapter:Error on receiving service object:java.loang.NoClassDefFoundError-com/wm/adapter/sap/rfc/value on functionName[ljava.lang.Srting


java.loang.Exception:Adapter values are not available.

hi could u please provide me quick information on bove query:
we have checked all connection are enabled

I have one more question…please provide me information…

[INDENT]Hi rmg,

when i am creating the sap adapter service i am getting folling error.can u please provide the info what should i check:

Failed to create the adapter service.
com.webmethods.developer.adapter.metadata.AdapterMetadataException:com.wm.app.b2b.server.serviceEception:[ART.114.243]Adapter Rntime(metadata):Failed to run resourceDomainLookupValues service.Details provieded in error log.
[SAP.101.9055]WmSAP Adapter:Error on receiving service object:java.loang.NoClassDefFoundError-com/wm/adapter/sap/rfc/value on functionName[ljava.lang.Srting


java.loang.Exception:Adapter values are not available.
[/INDENT]

What Adapter version you are using now back to?

Also is the WmSAP package fully loaded with out any errors after IS startup?

HTH,
RMg

currently i am using WmSP package version is:7.1 and IS also 7.1

i found sap package is loaded with out any erros.

Thanks and Regards
Giridhar

below are the server logs for the SAP adapter loding:

2012-08-13 11:11:09 MEST [ISS.0025.0011I] Package Replicator Manager started
2012-08-13 11:11:09 MEST [ISS.0028.0001I] Loading packages
2012-08-13 11:11:11 MEST [ISS.0028.0005I] Loading WmRoot package
2012-08-13 11:11:14 MEST [ISS.0028.0005I] Loading WmDB package
2012-08-13 11:11:15 MEST [ISS.0028.0005I] Loading WmFlatFile package
2012-08-13 11:11:16 MEST [ISS.0028.0005I] Loading WmART package
2012-08-13 11:11:18 MEST [ISS.0028.0005I] Loading WmJDBCAdapter package
2012-08-13 11:11:18 MEST [ISS.0028.0005I] Loading WmSAP package
2012-08-13 11:11:20 MEST [ISS.0028.0005I] Loading WmRemedyAdapter package
2012-08-13 11:11:20 MEST [ISS.0028.0005I] Loading WmVCS package
2012-08-13 11:11:24 MEST [ISS.0028.0005I] Loading WmPublic package